Grounding issue from USB to Frame

Out of nowhere I’m having the grounding issue. It didn’t do it initially and now it started. What is the fix that everyone has done for this issue?

Do you have a laptop? Does it use a charger with a third prong?

I believe I having the same issues. Was able to make 3 cuts then all of a sudden on the 4th cut it keep saying that the voltage was lost. I went through the problem solving steps and updated firecontrol.

This afternoon I was able to get through 1 cut fully. On my 2nd cut the torch just froze while still firing. Fire control didn’t work so I shut off the plasma, waited 30 sec, turned it back on and the torch was still firing. I eventually had to turn the eltronics off on the table and the plasma.

If any one has any ideas on what could be happening would be great.

My problem was a grounding issue. I have a desktop, so I I couldn’t just unplug it like a laptop. So the solution they gave me was to take a the ground prong off of my computer cord. I used an adapter that went from 3 prongs to two. Now everything is running like it should.

1 Like

Interesting. I don’t know what the hell is going on with mine…

I will do some more research and try to problem solve it again tomorrow.

That is likely noise interfering with USB communication. Do you have the USB cable looped through the choke nearest the electronics box? If so let us know and we will send you a second choke.

For some reason we havent quite figured out, some plasma cutters emit more noise than others. For example, all of our machines here run razorweld cutters with no chokes at all on the USB cables. We have an AHP blowback cutter that will cause FireControl to freeze UNLESS there are at least 4 chokes on the USB cable all looped through twice. We have customers that use the exact same plasma cutter with no noise issues at all. The variability of the occurrence makes it challenging to solve, but we are looking into putting further noise suppression on the board to prevent the issue further.

1 Like

I would definitely be willing to try a second choke. I am running the Razorweld 45. It is as far as the USB cable provide will reach.

Ok Langmuir. After all afternoon moving my plasma cutter around in various locations (obviously only as far as the cords will reach) this is the set up I found to work with no error. I also unwound the loops going through the choke as well. I only have 1 complete loop now.

I have yet to do a large cut in fear of the plasma or program freezing but I was able to do about 6 - 3" circles playing around with kerf, lead in and pierce delay.

This is not ideal. I was hoping my plasma was going to sit on the bottom shelf of where my laptop sits. There has to be a better solution. Please advise. Any suggestions would be highly appreciated.

the plasma is under that piece of cardboard on the floor. I was worried about water splashing.

i believe you need the 2 loops in the usb cable with the choke around them.

This may seem weird but I had worst results in getting everything to work with 2 loops. I even took the choke off at one point. 1 loop seems to work. I will be doing more test cuts tomorrow

Can some one please give me some pointers here. I am lost. Yesterday the plasma table worked with the set up shown above and now I cant get it to fire at all. Every time I tried it send me an error that arc voltage was lost.

Are you saying that the plasma cutter is failing to fire now? When you command it to fire with FireControl do you hear the relay click?

@langmuir-daniel The relay inside the plasma was clicking on. I did not touch the setup from yesterday when I finally got it running.

I did however get it running just now. I unplugged everything and restarted my computer. Not sure why its so sporadic.

Thank you for the immediate response

I see that you are using a magnetic ground clamp. just to rule out all “extra” accessories, you might want to attach the work clamp straight on the metal until you figure out what’s going on.