Gantry not moving ( Solved )

I have my crossfire set up, motors work but gantry only moved 3/4 down rail and stopped and won’t move now at all?

Is the coupler between the motor and the lead screw slipping?

Is the motor powered on?

Is the motor plug securely pushed into the electronic enclosure?

Is the bearing adjustments a little too tight and it’s binding?


It all moved while on jogging then on the return it stopped 3/4 of the way back. I feel like a idiot asking these questions, sorry

Set jog speed down to 100 ipm on fire control screen and see if will move at slower speed.

1 Like

Did you just put this together? Loosen the bolts on the bracket holding the motor to the support tube and look to see if it moves
Open the control box, use a multimeter on DC voltage, and ensure you have 36v.
Ensure your motor connections are completely seated and don’t have burnt pins.
Finally, make sure the nut on the end of the lead screws is not too tight.
Is this a pro or a std crossfire?

1 Like

If it’s a Pro then BOTH Y axis motors have to turn at exactly the same time and rate. If one slips then the whole gantry can twist and jam.


Standard Crossfire

Has it ever worked?

Both motors spin. It worked one time and stopped @ 3/4 of the rail coming back.

Open up the control box and check the power supply for 36 volts DC.
Adjusting power supply voltage.pdf (1.8 MB)

1 Like

Loosen these two bolts just a hair and see if the bracket squares itself up. If it’s not square it, will put the lead screw in a bind.


Issue Resolved. Thanks for all your help

1 Like

I thought this thread was for someone else?

1 Like

Now, I am confused more than usual. Well, what was it that fixed the problem? Oh well.

I’m not sure what pcakes issue was n the first place

I’m assuming that the two are working together. Oh boy, there I go, thinking. Nevertheless, it is a closed thread. Hopefully, one of the two will let us know the fix so other users won’t have the issue.
Sorry, Jimmy, I love this picture. It says it all.


It’s the same person, some how I am logged in under different names. Will get that fixed. I followed what you told me to do.


So this was the fix?