Firmware update message

New table set up. I have updated my firmware. Was given a confirmation message.

However, when I try to upload a file the message I get is: "The program you are attempting to load has been processed with a later version of Post Processor. You must update your machine firmware before loading this program.

I draw with BobCAD V35 and am using their processor. All the latest versions of softwares and firmwares are being used. Can anyone advise?

Basically, there are only two post processors that play well with FireControl: SheetCAM and Fusion 360. If you shared a DXF or SVG, someone on this forum could send it through one of the approved systems and send you the gcode (nc or tap) file.

Also include your metal thickness, plasma cutter and any parameters that you want included/modified (cut speed, cut height, kerf width).

If you find that you are unable to attach a file, there is a magic number of posts that you need to make before that feature is turned on. Not sure if that also applies with sending direct messages to people.

To try with direct message, you click on their identification logo/profile pic and then you will see the word “Message.” Click on Message, and see if that allows the insertion of a file. To insert a file, look for the up arrow icon in the tool bar:

SheetCAM has a trial time period and Fusion 360 is free for hobby use.

I am assuming that this means that BobCAD’s version of the Firecontrol post processor is an older version that is not supported by the current firmware. The “update” it is asking you to do, would actually be a downgrade to an older firmware version.

If you could upload a cut file that was made with the BobCAD post processor, we could tell what needs to be changed.

I have downloaded Fusion 360 Personal and SheetCAM. In the middle of getting Sheet finished and open. If I import a dxf. into sheet I can post process it then upload with Firecontrol? Or does sheet take the place of Firecontrol? These softwares are new to me and I am not up to speed yet on them.

@csdrag Here is an official link to the software work flow

Basic flow is

Design software to create a SVG or DXF file.

CAM software to take that design file with the correct post processor and turn it into G code, a NC or TAP file.

Then Firecontrol takes the g code and runs the machine.

1 Like

Thank you. I have downloaded purchased SheetCAM. I have created G code. I am haaving trouble understanding which post processor to choose within the SheetCAM list. Can you advise? I chose Mach 3 randomly and it did not work. Thank you

SheetCAM Post v1.6

Here is the from the download section

1 Like

Thank you for reply. I have SheetCAM Post v1.6. I have imported it to sheetcam post list and selected it. I still get the original message to update firmware when I try to upload the saved tap file from sheet. I am missing details or misunderstanding something.

I am not sure then .

One of the SheetCAM guru may have some insight.

number 2 on this list is how to use the post processor, which it sounds like you have done.

Thank you for your help

1 Like

Are you saying that FireControl is asking you to update firmware? That is definitely possible. If so, you might need to go through that process. There has been an issue that FireControl asks for you to update from v1.6 to v1.5 and most of us have finally just done it. When you restart FireControl, it nags you to update from v1.5 to v1.6. Just do that, and it is resolved: whatever was happening in the background.

If it has nothing to do with FireControl…then, nevermind.

I do the update but nothing changes. I have restarted software, computer and the machine after updating. Still the same.

Are you talking about Fire Control?
If it is firmware, you might need to turn off the enclosure power, turn back on and then restart FireControl.

Yes. I have done that and still same results

What version does FireControl say you are currently at and what are they saying you need to update to?

21.1.5. I have a couple versions of same file saved from going through all this. One message is that the file was made with a later version of post processor. I must update my machine before loading. Another says I have attempted to lad a program that was posted with an out of date processor. Please update Post Processor to V1.0. Then it says in the meant time, Fire Controll can convert this program to make compatible now. Choose convert save. Choose this and nothing happens.

Sounds like you should be at the correct update. Are they telling you that this needs to be updated to a specific version or simply “it needs to be updated?”

Is this when you are loading a g-code that was post processed by SheetCam or Fusion 360?

Somehow, FireControl is not functioning properly. Are you using a laptop and does any of this relate to your operating system?:

This following information is from a PSA that Langmuir put out relating to another issue but it may involve what you are experiencing:
The vast majority of reports come from AMD Ryzen processors with the “-U” suffix. CPU model designation nomenclature indicates that these processors are power-efficient models. We’ve also rarely seen this issue occur on AMD processors with an “-H” suffix (indicating a high-performance mobile model variant) as well as even more rare occurrences on Intel processors with the “-U” suffix.

If you are relying on a laptop with such a processor to run FireControl, I strongly recommend that you disable auto-updates for Windows. To determine which processor your device is equipped with in Windows 10 or Windows 11:

  1. Navigate to Settings > System > About.
  2. Look under “Device specifications.”
  3. The name of your computer’s processor and its speed are displayed to the right of “Processor.”
    Here’s an example from my computer:

My device uses an Intel Core i7-12700K. because the letter at the end of the model designation is not a “U”, this device is in the clear for this issue.

@csdrag If none of this seems to apply to your situation, you should send an email to Tech support:
Pro Support | Langmuir Systems

Just for fun, try to load this g-code file, in FireControl, that I have loaded last week on my machine:
Golf Cart (6.1 KB)

Don’t attempt to cut any metal. Just see if it loads.

My computer is a laptop. Intel(R) Core™ i3-71000U CPU @ 2.4GHz

It does not load. I get the message that says the program has been processed with a later version of Post Processor. Must update machine firmware.