FireControl 20.6 Now Available - Release Notes

Whats NEW in 20.6

Langmuir Systems is excited to launch the next version of FireControl. Our team has worked hard on this update in close contact with members of the community to make this the most reliable and new-user friendly version yet. FireControl 20.6 includes many bug fixes, enhancements particularly centered around performance and resource usage, as well as a number of really cool features we’re excited about.

  • Drastically reduced resource usage - FireControl 20.6 uses much less memory and CPU than previous versions. Run FireControl on less performant computers with less freezing. This version also performs much better with dense G-code programs.
  • Line Select in Visualizer - Hover over a line in the visualizer and click it to highlight the associated line of G-code.
  • Patterning - Multiply your part in an organized fashion directly in FireControl
  • THC Test Wizard - Helps diagnose common THC issues with an easy step-by-step wizard by dry firing your torch.
  • Cursor Work Position - Visualizer shows location of mouse cursor in your workspace.
  • UI Scaling - Automatically scales for fitting all UI elements on smaller screens.
  • Revert Program - Allows for easy way to go back to the unaltered version of the program.
  • Progress Indicator - Progress bar shown across the top of the visualizer.
  • Connection Help - Help troubleshooting connection issues allowing re-flashing of firmware.

This release also includes the latest LS-THC firmware (v1.10) which includes messaging updates for Arc Voltage Not Detected errors to help users resolve these issues quickly. The core algorithm remains unchanged from v1.09.

Our team is still working on a fix for in connections MacOS 11 and will release a hotfix release whenever that is ready.

As always, if you have any questions or comments, please reach out to or post your comments here.


Been using this for about a week prior to release. Def the best upgrade so far. I had no freezes during any runs. The Line Select wizard is very helpful to getting to your desired part you wish to cut.

What you will notice different is when THC isn’t detected. When that icon pops up, don’t be alarmed when you hit cancel and it restarts the whole program. Cause that will happen. Since you can now go and select the part you wish to cut that is much easier to deal with. LM says they will fix that cancel option on the next version.

I really like the cursor work position, so you can see the coordinates.

The progress indicator isn’t that great of a feature that Iv noticed yet.

Overall Much needed version. Glad to have used it bf it launched. Keep up the great work!

Just ordered another pro table too! Despite the ups and downs Iv had, this is my 4th table.


Line Select



Wondering if its just me or if anyone else is noticing issues with keyboard shortcuts not working? My laptops on its way out so that could be the cause as well.

1 Like

Yeah this is great.

Well I have 4 times the torch rose off the work for no reason…
I am going to have to find and run that video monitor program to see what the is doing.
Because when things go wrong the first thing on hand is trying to save the work and stop the progea

Have you noticed things like tab and space not working intermittently? Seems like the keyboard short cuts only work 25% of the time.

Also looks like spacing in the new patterning function isn’t working? I love that feature btw.

I haven’t updated yet, lol. It sounds good though. I have a few orders to fill and didn’t want to risk something unfamiliar slowing me down.

1 Like

It appears to be written in the same language as Inkscape (Python, I believe) and I have this problem with Inkscape in a daily basis. It’s extremely frustrating. I don’t use the keyboard on Firecontrol, so I can’t speak to that, but if it affects one, it likely affects the other, as it appears to be a Python problem, not a program problem.

Its odd because they worked flawlessly in 20.5.

i made a sign yesterday, only had one voltage failure with several hundred pierces. missed a short section in my cut file and tried to use the straight cut command. once i entered the information and generated the code, i could no longer jog the machine. and the run program button never highlighted so couldnt cut it. had to restart firecontrol. did it several times and it froze up each time. also seams like it was cutting with the torch height higher than normal. didnt do the double touch before firing like normal. going to re-install 20.5.

Update sounds great - will be trying it very soon! Glad to hear you were working the pre-release with @directioneast! I’m hopeful it gets some of his issues out of the way… :+1:

The double touch was a feature in 20.4

Its working much better for me, laptop windows 10. The straight cut feature I never tried, but just so happens I did try it the other day and it wouldn’t work at all, since tried again and no avail. I contacted LM and seems they may have fixed it bf the final release. So, I may redownload and see if I can get that to work.
Iv cut last two weeks, 3 days a week for about 5hrs a day and had no issues. I was able to pickup time with misfires bc of the new selecting features. The auto detect for a misfire still doesn’t always pickup, so I have to pause the run manually sometimes. Iv had this issue from day one with 20.4, 20.5 releases. Overall this has been the best two weeks of cutting I’v had since running this setup.


I just updated tonight. I’m having a lot of issues with keyboard short cuts intermittently working, I’ve been trying to generate straight cuts and it keeps freezing. Once I got one cut finally work. I moved and zero all axis for the next straight cut only to find it some how tried to start where my previous cut was. I’m on attempt 5 to generate a second straight cut to cut remnants off.

Dang, sorry to hear. I guess Im gonna hold off on the new patch and keep their trial version for a bit bc its working just fine. My keyboard shortcuts are working fine.

Here is something I did notice about that and may or may not be the issue for some. In FC if you click outside of the program or on certain parts of the program it has this glitch where anything you hit including keys won’t work, so what Iv done is go and click on something withing FC like the add pierce delay or something. Then after that everything works. Iv noticed this way back on 20.4 I think. Hard to explain but there are times where it seems like FC is up and running but you can’t access it with the keys. I don’t need or use the straight cut enough to be alarmed but man I hope all these things can get ironed out. Iv had ups and downs with the machine and FC plenty and didn’t want to deal with all that. But I want to see this succeed.

1 Like

Hi All-

There were a few issues with the initial 20.6 release that were causing users some headaches. We have just released a hot fix (v20.6.1) now available on the downloads page that fixes these issues.

This fix corrects issues with:

  • Straight Cut stuck in Check State
  • Arc Voltage errors shown when Pause button hit
  • Hotkeys not working (Space to pause)
  • DRO editing not saving with Enter

You will have to uninstall v20.6 and install the new v20.6.1. To uninstall, click the search icon in the task bar next to the Windows icon. Type in Add then click ‘Add or Remove Program’. Scroll down in the list and find FireControl. Click on it then select uninstall and follow the on screen prompts.


Thanks for the update. Still am having issues with the tab key. Just me?