FireControl 20.4 Now Available - Release Notes

We are pleased to announce the release of the latest version of FireControl (20.4). Our team has been hard at work improving our machine controller. These updates include many user submitted ideas we are excited about and hope you are too.

This release cycle was cut a bit short due to a desire to quickly release performance improvements so some promised features will be present in the next (20.5) release.

20.4 Features:

  • Improved System Resource Use: Reduced CPU, GPU and memory usage while running with and without visualizer.
  • Manual DRO Updating: Set current position to arbitrary value. Click on DRO value while Idle to set.
  • Pierce Counter and Torch Time: Keep track of wear on consumables with resettable counter.
  • Download Program: Download a rotated, scaled, or run-from-here program to run again.
  • Visualizer Greyed Cut Paths: Paths that have been cut or moved through will turn to grey in the visualizer.
  • Bug Fixes:
    • Unwarranted ‘Duplicate G-code’ and ‘Numeric Value’ errors no longer triggered by controller buffer overruns on valid programs.
    • Moves during Soft Resets no longer losing Zero position.
    • Other minor improvements.

I just upgrade my Fire Control and experience several issues.

  1. After upgrading, opened fire control and tried to load a cutting file that was previously used it and just stay buffering the loading. End Task was used it.

  2. After end task, opened fire control again and this time did not recognized the THC. Restart computer and so far so good.

I hope this help!!

I upgraded fire control and now it wont open. Restarted computer and tried again and still wont open. Any suggestions on what to do?

If you are on Windows cut and paste this into a File Explorer:

And then delete that directory.

If you can’t delete the directory, reboot and try to delete again.

Alright Got it to open. Thanks for the help.

so If I download what is on the downloads Page is this the version I am getting ?

yes. it has the latest version showing (20.4)