Fire control error child process exited with code 1

A fatal error has been detected by the Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffd952facd4, pid=9812, tid=17144

JRE version: OpenJDK Runtime Environment Temurin-17.0.2+8 (17.0.2+8) (build 17.0.2+8)

Java VM: OpenJDK 64-Bit Server VM Temurin-17.0.2+8 (17.0.2+8, mixed mode, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)

Problematic frame:

C 0x00007ffd952facd4

No core dump will be written. Minidumps are not enabled by default on client versions of Windows

If you would like to submit a bug report, please visit:

Issues · adoptium/adoptium-support · GitHub

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

--------------- S U M M A R Y ------------

Command Line: -Dfile.encoding=UTF-8 --add-exports=javafx.controls/com.sun.javafx.scene.control.behavior=ALL-UNNAMED --add-exports=javafx.controls/com.sun.javafx.scene.control=ALL-UNNAMED --add-exports=javafx.base/com.sun.javafx.binding=ALL-UNNAMED\Users\laven\AppData\Local\FireControl\FireControl.exe com.langmuir.cnc.machines.firecontrol.FireControl

Host: AMD Ryzen 5 5600H with Radeon Graphics , 12 cores, 5G, Windows 11 , 64 bit Build 22621 (10.0.22621.1105)
Time: Fri Feb 10 09:56:11 2023 Central Standard Time elapsed time: 5.406841 seconds (0d 0h 0m 5s)

--------------- T H R E A D ---------------

Current thread (0x000001baefd63a20): JavaThread “OpenGL rendering” daemon [_thread_in_native, id=17144, stack(0x0000007332b00000,0x0000007332c00000)]

Stack: [0x0000007332b00000,0x0000007332c00000], sp=0x0000007332bfe670, free space=1017k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C 0x00007ffd952facd4

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.eclipse.fx.drift.internal.jni.win32.NVDXInterop.nWglDXRegisterObjectNV(JJIII)J+0
j org.eclipse.fx.drift.internal.jni.win32.NVDXInterop.wglDXRegisterObjectNV(Lorg/eclipse/fx/drift/internal/jni/win32/Win32$HANDLE;Lorg/eclipse/fx/drift/internal/jni/win32/Win32$IDirect3DResource9;III)Lorg/eclipse/fx/drift/internal/jni/win32/Win32$HANDLE;+12
j org.eclipse.fx.drift.internal.backend.NVDXInteropImage.allocate()V+89
j org.eclipse.fx.drift.internal.backend.SimpleSwapchain.allocate()V+75
j org.eclipse.fx.drift.internal.backend.BackendImpl.createSwapchain(Lorg/eclipse/fx/drift/SwapchainConfig;)Lorg/eclipse/fx/drift/internal/backend/BackendSwapchain;+22
j org.eclipse.fx.drift.internal.RendererImpl.createSwapchain(Lorg/eclipse/fx/drift/SwapchainConfig;)Lorg/eclipse/fx/drift/Swapchain;+5
j com.langmuir.cnc.machines.firecontrol.visualizer.GLPane.updateSwapChain()V+47
j com.langmuir.cnc.machines.firecontrol.visualizer.GLPane.glLoop()V+22
j com.langmuir.cnc.machines.firecontrol.visualizer.GLPane.lambda$initGLThread$0()V+21
j com.langmuir.cnc.machines.firecontrol.visualizer.GLPane$$Lambda$
j java.base@17.0.2
v ~StubRoutines::call_stub

siginfo: EXCEPTION_ACCESS_VIOLATION (0xc0000005), reading address 0x0000000000000058

Welcome to The Forum and check out this topic

1 Like

Is there any fix for this. I have this same error as of today. 4 months since Ive used the machine and now is inopertive.

Hey Robbie,

The thread that @TinWhisperer linked back in February is still accurate. The issue stems from a recent Windows update, that affected drivers for power-efficient models of AMD processors (and a few Intel processors).

Unfortunately, rolling back the update would not resolve the issue, as it does not roll back driver files.

Hypothetically, rolling back to a restore point created before the update should revert the driver back, but I have not tested this to confirm because most users are not regularly creating restore points.

1 Like

Unfortunately I have not created a restore point either. I have gone back to my windows ten Ave I have the exact same error. Is there a work around that Langmuir is offering. At this time I have a useless piece of equipment along with a laptop that’ was purchased specifically for this? I’ve installed this on two laptops today and the same results. Is Langmuir willing to buy back my equipment??? No joke!!

1 Like


Here is a video about a tool that will allow you to revert to an older version of windows 10

Could you post the laptop specs and Windows 10 version of these two systems. This may help in understanding where the problem exists for you.

Any to get everything thinking about their setups, windows 10 ENDS OF LIFE is about 2 years way

“Windows 10 will reach end of support on October 14, 2025. The current version, 22H2, will be the final version of Windows 10, and all editions will remain in support with monthly security update releases through that date”

1 Like

This is exactly the reason that I run my table with a mini PC that is not connected to the Internet in any way.

My version of Windows 10 works fine and there is no need for security updates with no internet connection.


I found that the problem is in the amd graphics driver, if I uninstall the amd vega driver and use the Microsoft basic display adapter the program runs without the error. Seems like windows will update the driver again, and the error will come back until I uninstall it again. Easy to do with the device manager, and once the program is running and it updates the driver it won’t kick you out, just give you the error when you first open the program. It’s not a permanent fix but a good work around. I’m gonna try an earlier driver version and see if that works. I hope this helps someone


welcome to the forum…and what a great way to post…
Great advice and a great work around…well done!!!