FireControl keeps crashing on startup

Was child in the error?
I did find “Exited with code 1” on google.

Yes I pasted the error message word for word, I have tried google searching the issue but most of what I find is basic troubleshooting and none of it corrects my problem.

That is nothing I can help with. I just wondered about the word “child” being in there. Very weird

You should probably address this to @langmuirsystems and @langmuir-reilly

I’m also moving it to software, Firecontrol

And welcome to the Forum!

1 Like

Thank you. If I cannot resolve the issue on my own soon I will definitely reach out. I’m currently trying to update windows to see if that fixes anything. It’s just weird because I haven’t had problems with it until today.

Hey Wayne,

Does your computer happen to have an AMD processor? If so, which model specifically? We’re aware of a very rare issue with a recent Windows 10 update that causes this OS-level error when trying to run FireControl - it seems this update is affecting certain processors.

One user was able to resolve the issue by simply uninstalling and reinstalling FireControl - others have found success by updating their CPU drivers or motherboard’s BIOS. Keep in mind that the latter two are relatively drastic steps; I recommend starting by uninstalling/reinstalling FireControl and see if that resolves the issue for you.

Unfortunately, due to the rare nature of the issue combined with the fact that it stems from a Windows update, at this time all we can do is provide suggestions that might work and collect data that may help us formulate a consistent fix.

@Knick A “child process” is a subprocess created by an application - for example, the visualizer and the DRO are two child processes of the parent process FireControl. The CPU distributes child processes to multiple threads to enable concurrent processing; a child process error can occur when one or more threads have an error.


Yes It does. I have tried to uninstall and reinstall FireControl, also tried installing older versions, tried running it in compatibility mode, tried updating windows, nothing has worked so far.

Host: AMD Ryzen 5 PRO 3500U w/ Radeon Vega Mobile Gfx, 8 cores, 13G, Windows 11 , 64 bit Build 22000 (10.0.22000.1219)

The “-U” suffix in the model number indicates that the processor is optimized for power efficiency - I find this very interesting, as the only Intel user that has reported this error also had a power efficient CPU.

Are you able to launch FireControl while your computer does not have the USB cable plugged in? Or does it still throw the error?

If you’re on a laptop, there should be a battery icon on the right-hand side of the Taskbar (see attached screenshot). Clicking the battery icon brings up a slider that allows you to balance between battery life and performance. Where is that slider currently set? Does sliding it all the way to “Best Performance” resolve the issue?

Screenshot (18)


Thanks for explaining that. And I just to say you guys really do a great job helping people. It just amazes me !


No I cannot launch FireControl with or without the USB plugged in. Also changing the performance options for the battery didn’t resolve the issue.

So if it’s windows update that might be causing this, can you see if your computer was updated about the time the problem occurred? And if so go back to the previous one?

I can check to see but I’m really not sure when the problem started. I noticed today but its been a few weeks since the last time I used FireControl so I cant say when the problem actually started. I can say I have not had any issues with any other software on my PC. I’m currently using Fusion360, SheetCam, and Ultimaker Cura, no issues.

1 Like

The computer that we use in-house to quality control test the Electronics Enclosures also happens to have a Ryzen 5 3500U - it’s still running FireControl for the QC tests just fine, and it’s on a not fully updated version of Windows (I turned off auto-updates and WiFi to make sure it stays that way).

I’ll do some investigating and keep you all updated.


I Uninstalled several updates and updated the BIOS. Still nothing. At this point I don’t know what else to do. Thank you for the awesome customer support. Please keep me updated with any solutions you may have.

Following…I am also having the same issue Ill update if I come up with anything…

1 Like

any updates I just bought this computer an I am having the same issues

1 Like

If worked efore i woukd try restoring computer back to an earlier set point say at least a month and see if it works and if it does turn off automatic updates. We keep automatic updates turned off because of various issues related to updates. Easier to update later once bugs are resolved.

1 Like

I had the same issue on 2 different computers. I believe it started after windows update. On the laptop that I normally run my Pro off of I tried uninstalling the last few updates but that didn’t work. I did a fresh install of Windows 10 and didn’t do any Windows updates and Firecontrol seams to be working normally. On my other PC I will keep trying to remove Windows updates until it works or support finds a solution.

When you installed a fresh copy of windows 10 did it remove everything from your computer? I guess I can backup all my files to USB but I’m trying to avoid this although it seems like the only option at this point.