Everlast 50s Problem

You all know I’m no newb, so I have searched for the answers to this to no avail… I have an Everlast 50s and it has worked flawlessly up to this point. The problem I am having is that now it seems to stop working intermittently, not during cuts, but during ignition. It doesn’t fire, I stop the machine, back up to the M05 (I use probing) is probes again, then nothing. It seems the air continues running for a long time after cutting, not normal, one the air stops and I restart, it fires no problem. I am not getting any indication of it being overtemp, no lights on the plasma unit, air pressure is good, air is DRY, and changing consumables does not affect anything. This will happen with brand new consumables. I have also tried 2 different torches and I get the same thing. I did have a problem with my air dryer freezing up at one point, and I had air pressure problems at the unit, pressure to low. I let everything sit overnight and air pressure at the unit is not a problem anymore. Anyone have any ideas? “ground” is directly clamped to the work piece. I am thinking it may be something with the plasma unit because of the almost constant running of the air after the cut. Any help would be greatly appreciated. Unit is only 6 months old, so I am also going to put a call into Everlast as I bought it directly from them. Thank you!

Yeah sounds like something is not right. There is a dial for the cooling air time did it get bumped to max by accident ?

Just wondering Dicky. Is your shop heated? Is it possible a valve in the machine is freezing?
My Miller was acting up a little yesterday with funky air flow, then it cleared up. I was thinking It may be due to the cold we had last week.

1 Like

Yes it is heated. I keep it at 48 when I’m not in there, 60 when I’m working.

No, I checked it, still where it was 15 on the dial.

In your consumables did you try a new swirl ring? My thinking is that if the swirl ring is partly clogged you won’t get the blowback function for the pilot pilot arc to start. which if I read this right thats what you aren’t getting no pilot arc sometimes.

I’ll give that a shot tonight, I didn’t even think to check that, thank you!

I had a similar issue with my Everlast. I discovered that if I tighten the torch head too tight to the torch holder, it would not fire. So try firing the torch after removing it from the holder, or loosen the set screw on the holder until it fires. I don’t kmow why it makes a difference, but it does.

I had the same problem with my 50s. I found if I tightened the electrode too tight it would happen. I also took my torch apart and polished all the pieces with superfine sandpaper as I thought it was sticky.

Cleaned everything and it still does it. Once I stop cutting the air keeps going for a long time. If I switch the cutter off, air stops, switch it on, cuts normally for a bit. I think it has something to do with the aur and the blowback start

I dont have time right now to completely diagnose, have a lot of orders at the moment. Also, I have 2 torches, both do the same so I’m convinced it’s something in the plasma unit itself

Just for giggles, have you pulled the fuse out of the front of the machine and checked it? I remember I was having issues because I was grounding to a painted clamp instead of directly to the table and it popped the fuse

I’ll check that in a few, gotta go start cutting Xmas stuff for a craft show I signed up for tomorrow… lol, gotta wire my oven as well… Nothing like waiting till the last minute!!!

1 Like

Fuse was good. I got it traced down to the (i think) air solenoid in the plasma cutter. It’s not always releasing the high pressure burst to blow back the tip. The old tv with rabbit ears trick (bang on the side of it with palm) seems to make it work everytime now… Could be a loose wire inside… Will tear it apart another night, or with tech support on the phone… should be fun…

Have you contacted everlast customer service yet

Yes, they gave me something to try, but the next call i have to call them, be by the machine, open it up, test stuff… Then they decide if I send it back, or they send me parts… Kinda bull crap, but… I’m capable, and have the tools, but what if I didn’t?

come to think of it… I think my problems may have started when I changed air hoses… I’m gonna try the old hose… I think they are different diameters! Just noticed this last night… Update soon!

No difference with the hose… But I did take this video last night… Watching the video, it looks like I see a faint light in the temp zone, like it’s on, kinda… I would expect it to be as bright as the other ones… This may be my problem…

I think the problem is solved… It was the O-ring…



Everlast is sending me a new torch though…AND a rebuild kit for this one… I was just going to email them to see what additional cost it would be for them to send me a machine torch as a replacement and I saw the email from UPS that the torch and rebuild kit are on the way… It took about 8 emails back and forth sending pictures and such to get it done, but I’d say my experience so far with their customer service is pretty good!