Everlast 50s Problem

I have the same plasma cutter, and it seems to be working fine, when I use it by hand, off my metal welding table; but when I try to use it with my crossfire pro with aproxamatly the same cutting height and travel speed, it wont keep a cutting arc going after piercing through the metal. Instead it just keeps the pilot arc going. I have the work clamp clamped directly to the material, and I tried replacing all consumables; so I don’t know what might be stopping arc.

I have the same machine,from new mine wont stay ignited above 20psi, if i dial it up to 70psi the torch stop starts continuously. Any ideas please. I have replaced consumables, checked wiring. It cuts ok at 20psi and below only in thin material.

Hi there, I’m new to the forum.Have been having a similar problem with my PowerPlasma 50S. I purchased it in 2016 and set it up once to give it a test run and it worked as it should. In the meantime I lost access to a workspace so it sat in a corner of my livingroom until June 2020. When I went to fire it up to do some sheet metal work on my truck…No Pilot arc. I have been in contact with Everlast Canada and they have been suggesting a few tests I can run to try to diagnose the problem . ( https://youtu.be/aTbBKnNvUOQ)
After viewing this video they suggest I try a Blowback Oupput Voltage Test to help determine if the problem is with the machine or the torch. I will attempt to perform these test today( February 27,2021) and record the results. I have taken note of all the suggestions in this thread and checked. All appears OK. What was the problem with your O-Ring? Did it look OK? Was it missing?
I may just have the bad luck of having received a faulty unit or I am inadvertently doing something wrong. In any event the warranty expired in 2019 and I am on the hook for all costs associated with repair. I am hoping it is something simple. Any suggestions? Thanks in advance.

I though Everlast was under warranty for 5 years.

…I have had a couple of Everlast units…

open up the unit…go through all your connections…check for anything loose…
I had a friend nearly have to buy a new Plasma as a few connectors came loose inside…preventing it to fire…
check the wires also…

1 Like

3 years Canadian which equals 5 years American if my math is correct :slight_smile:

I did have the cover off once and took a quick look. Didn’t want to poke around too much as the unit had been plugged in shortly before I looked. I’ll look a little more thoroughly next time. Thanks

smart…better to be safe than…

Anybody have issues with regulating the air pressure? I turned on my machine this morning and with no air connected it read 74PSI the amount i usually have it set to while working. I turned it on and off and contacted support. Looks like im gonna have to send my machine to them…

I got so much work to do a whole weeek + is gonna tough. Worst thing is mine is only like 13 months old!

When ever I turn it back on it goes back to 74 PSI When i plug the air in goes up to like 143 PSI So i cant run the air.

Install a regulator on the back of the plasma cutter and set that for you cut pressure. That should get you through. The odds are the regulator or gauge is bad I would just replace it and be done with it. Shipping cost both ways will cost a lot more then the parts.


unfortunately that won’t work. When I regulate the pressure before it’s acting like 74 psi is my 0 so when I add 60 it brings it too 134 psi and the machine won’t fire when it thinks it’s that high.

The plasma cutter does not know the difference between 50 psi and 150 psi. If its not firing then something else is wrong.

1 Like

Unfortunately, the Everlast cutters with a digital air pressure display will not work if the pressure showing on the display is too high.

Well darn, I need to get up with some of these new style plasma cutters. :crazy_face: