Error from CutControl

We are at the point where we actually need to mill something! We exclusivly use SolidWorks. We created a part to be milled, selected the end mills and drills we want to use, and eventually created the G code file. We uploaded it to the MR1, and it gives us an error on line 227. I have attached the error it gives, and part of the file.

What is strange to me is that it has a problem with line 227, but up at line 206 it has the exact same line, but it gives no error on that. I am assuming that it error checks the file from top down. There must be something between 207 and 227 that changed the way it runs, and it doesn’t like 227 for some reason.

Anybody have a clue whats going on?

PS. My son, 17, is BIG time into robot combat, and we are milling out a weapon support, which he needs by Tuesday.


Turn off cutter compensation (G41/G42) and repost. CutControl hasn’t implemented anything except very basic g code.

1 Like

Thanks, that is very helpful.

We found one problem prior to your response. The fillets were smaller than the end mill. So we changed that, and it seemed OK. However, it had two issues:

It would not pause for tool changes, so it tried to use the same end mill for everything.

It would not drill anything. It went to the drill location, then stopped. We did more research, and our post processor was using G83, which is the canned drill cycle. We need to remove that and just have it drill a hole with a standard drill bit. We are still researching that.

CutControl doesn’t support tool changes. You have to post a different G-Code program for each tool and manually switch between them when you switch tools.

There is a beta with a different approach here, but still not full manual tool changing.

CutControl also basically doesn’t support any canned cycles, so you need to get your post processor to expand them to regular movement operations.

1 Like

great info, thank you. We stumbled onto both of those issues.

The issue is, we use SolidWorks CAD / SolidWorks CAM exclusively. We have looked everywhere, and we dont see a way to turn off canned cycles. I saw a post from somebody that claimed there is a way, but we have not found it.

So the current method is to make the .nc file, which contains the canned drill cycles. then manually edit them with Notepad to remove them, and add in G01 codes to drill the holes. This is a terribly inefficient way to do it.

Does anybody know where the control to turn off Canned Cycles is located? Is there a better post processor?

I made one that Skipshift did some testing on. I haven’t heard any issues or if any changes needed made but this one uses long code instead of canned cycles.