EMI/RFI, THC issues (Solved - laptop ground circuit issue)

New Pro with THC paired with a new CUT60. Spent a lot of time on this forum over the last few days with help from several people troubleshooting THC errors. Long story short, switched from my desktop (which has been working just fine) to my battery powered laptop…and THC works flawlessly. Switched back and forth a few times and the issue transferred.

USB resistance to frame was within LS spec, so is this a usb interference issue, or a grounding issue through the electrical system?

Has anyone ever installed an Isolated Grounding Receptacle with success? I am an electrical inspector and see this quite often with sensitive hospital equipment…anyone ever tried one?

Did your Desktop computer recently update its OS?

No, no changes on software.

Yes. @brownfox

Losing arc mid run - Langmuir Systems Forum

Also, you may want to follow this thread:

What USB noise isolator is recommended - Langmuir Systems Forum

1 Like

I actually never installed an isolator or anything special. My issue was 100 percent related to having my laptop plugged into a grounded outlet and only caused problems on thicker materials.

I have a usb powered pc on a stick that I’ve been using for two years now and I’m happy with it. I have usb and torch cables coiled up and sitting on top of each other, and stable cutting voltage within the right parameters and THC is great.


Great thank you. Similar results, laptop on battery power has given me zero issues so far. Thanks!

1 Like