CutControl 21.1.1 Beta Release

Hi All,

Our team has been listening to feedback from our first batch of customers and in response we’ve made some bug fixes to CutControl. We are making available the new version, 21.1.1, for download by using the link posted. Please also find a detailed list of changes in this version below. The next version of CutControl will feature additional bug fixes (as they pop up) as well as NEW FEATURES so stay tuned.

  1. New UI scaling system
  2. Added scroll bar for modules
  3. Fixed bug with alarm state after program check was completed
  4. Fixed visualizer compatibility with older machines (No need for compatibility version anymore)
  5. Introduced new proper UI scaling method that eliminates most of the artifact
  6. Made probing and tool-setter operations more full-proof for pausing mid-cycle
  7. Improved on screen keyboard styling
  8. Added machine menu that allows clearing alarms, hold state and soft-resetting machine
  9. Added machine connection failed popup
  10. Implemented probe monitoring during probe cycle positional moves to protect probe from breaking from incorrect user inputs.
  11. Fixed soft limit failure on boss/bore probing
  12. Fixed limit switch pop-up bug
  13. Fixed g-code arc error issue on long programs without smoothing (machine firmware)


I’m looking forward to new features, but this is fantastic. Thank you guys!!

I only had a couple of minutes to install 22.1.1, triggering a firmware update, and trigger a couple of toolsets. It looks like Z0 randomly being wrong after a toolset may have been fixed with a firmware update?

It would be nice if cut control displayed the current firmware version. It would be even better if there was a terminal to allow direct input of gcode (to allow m503 to be run).

First bug report: After installing a firmware update, the AVR resets and causes a com port error (expected) for the disconnection. Then the “home machine” dialog pops up over this. After clicking the home button, the homing dialog is corrupted:

1 Like

Better wait for the next official release then……

Does this release include the tool change option and gcode “run from any line” option?


I used the update all day without any issues.
I will say the machine homed every single time without skipping a beat.
Touch probe and the tool setter worked well.
No complants.


I must be a lucky guy… My machine being #2 has worked flawlessly since the the start. I have upgraded all axis to the high power controllers.
I did go through two probes due to not being able to zero the first one in. My second one is great. I do keep an additional spare in the tool box for a backup. Just in case I do crash it. I have made some awesome parts. Very pleased at this point.


Thanks @Bigdaddy2166. This gives me confidence to try. I will install it in the weekend and test some more stuff. I want to test probing a bore and milling it to check accuracy of the probe. Also I will test some drilling. Excited about this new release.

Does this one allows the tool change in a single program?

1 Like

No, I don’t think so. When drilling with standard stubby bits make sure you use Langmuirs drill guide. The sheet gives you all the parameter for all the standard sizes.
Cutting Parameters - Getting Started Reference Guide - Rev. 11_30_2022.pdf (71.7 KB)

1 Like

Installed update today, both the software & firmware both went smooth, no issues.
Machined 2 different parts, 3 probing cycles, 8 different G-Code files, again went smooth, no issues.


Running 21.1 and i updated to 21.1.1 and it crashes after homing. I keep having to go back to 21.1. Very frustrating.

CutControl beta is 23.1 and 22.1 is the original release. Are you loading FireControl 21.1 on a MR1? Or are talking about a plasma table?