Cut control issues reading program [RESOLVED]

So I’ve had this issue pretty much every time I run. The first program usually goes without an issues then tool change and second program usually produces a reset error. The cut path visualizer then zooms in close and obscures the view to an extent. I try to run program and it turns spindle on and ignores my first X Y move after G54 and begins the cutting path out of position weather a helical move or a drill z move as it was today. I tried running the program using the line by line option and it completely ignored the G0 in line 7. The third picture shows the position after line 7 executed. In the past the only way to solve with our shutting down cut control or the controller was to re post the program.

What are the last few instructions in the previous program? Is the system left in Incremental Mode?
Manually edit the second program and add a G90 on the same line as the G54. That will be harmless if it’s already in absolute mode, but will fix it if it’s in Incremental mode.

Also, what are the X & Y positions BEFORE line 7 is executed?

1 Like

I’d definitely recommend dropping a G90 on the G54 line and see if that clears it up. If the program ends in G91 (incremental) then the machine just moves from where it currently sits rather than in G90 (absolute) moving to a position relative to the G54 work coordinate.

I don’t believe so but I will have a peak. I have tried starting at different positions including the xy zero and it always positions to the coordinates shown in the 3rd photo (positional location). will give the g90 a shot.

In this case, maybe G54 wasn’t in effect when you did the first program?

that would be odd if it didnt use g54 as thats the reference i was using and the part and features all line up between the two programs.

Indeed, but I would consider your system’s behavior ‘odd’, so it would be consistent in that regard.

I added lines 2 3 and 4 to the beginning of my file and it works correctly now. Seems fusion leaves it out when it splits by tool for any op past the first one.

1 Like

Probe worked fine for the first setup but on this second setup my Z was about .150 low after recal of tool setter and setting Z height off part, almost took out my thread mill.

Did you find out why the z height was off .150? The same thing happened to me and I snapped off an 1/8 inch end mill. I found out it was operator error. I programed all of the tool paths off one setup. Then ran ops 1-3 with no problem, took part out and bolted it to fixture and re-probed part. Unfortunately the setup was using the stock height which no longer existed since I face milled the part, so the z height was off by .080 (the amount face milled). I realized my error when I saw how deep the small end mill plunged into the part.

Good, yes, probably not left in Incremental mode as MR-1 Post Processor probably doesn’t use that, but G20 would be essential to set position in Imperial units. The default might be G21, Metric. G94 and G17 would probably be default settings.

1 Like

I didnt dig into it as it was only a drill and threadmill op. I created setup 2 in fusion and the “stock” was just the model body as there was no more excess stock to cut. but maybe i will check. I reset the zero to the machined part and as I remeber the zero in the setup was based off of the model.