Crossfire pro wont connect

Hi Guys, new to the forum and to crossfire here… I purched a crossfire pro with thc and a razor weld 45 amp plasma cutter about a month ago , up until about a week ago everything had been working ok other than having issues with the thc not working very well at all but thats a problem for another day… all of a sudden my lap top which is running windows 11 home, which was working fine, stopped working in fire control, it shows connected in the top right corner, the green light on the control lights up, when i click on the connected window it just shows fire control(). but thats it, i can see the com ports light up in device manger (both the plasma and the thc), but all features in fire control arent working, it doesnt let me home or jog or anything… everything is basically greyed out… i have another lap top that is also running windows 11 home and it works fine, so its something with my lap top…i havent changed anything, i did see 2 windwos updated from about the time it quit working so i delted those updates but it didnt help… i just cant figure out whats going on here? I have tried uninstalling/reinstalling the software twice, and deleting the cache file as someone on here suggested, i have seen people suggest deleting the drivers, but so far as i can tell those are a package deal with the software version please correct me if im wrong? if so where are the drivers located because i cant find them? im at a loss, anyone got any ideas?

See if something on the firecontrol support page helps…

Hi @DonP and thanks for the reply… I have tried this, when i click on the connect drop down bar it shows fire control (), when i click on that nothing happens, everything just stays greyed out?

They have some troubleshooting in that link above to hopefully resolve your issues. If corrupt you need to reinstall.


@DonP Hi Don thanks for the help, Ive got nothing here… I read through and tried all of the troubleshooting tips in the langmuir link you provided above, ive tried uninstalling/reinstalling the software multiple times, uninstalling and letting windows auto reinstall the usb drivers , fire controll is still unresponsive and not making a connection on my pc, everthing is greyed out. Its interesting that in the trouble shooting lonk it says sometimes you have to manually connect, but with my lap top its not an option if a connection cant first be established, with my co workers lap top it is after a connection is first established, but so far as i can tell, fire control basically has to already have established a connection to manually discnonnect/reconnect, this works with his but not with mine :frowning:

heres what i see

I can’t remember asking if you plugged something else into that USB just to confirm it’s working. I’m guessing you have but figured I would take step back.

Found this posting that might help…

@DonP yeah all 3 usb ports are working on my lap top i use them daily for other devices like hooking up to clearpath servos through msp etc… I also tried uninstalling and reinstalling the drivers but it didnt help… its a real bummer im currently using my friend’s lap top which is nearly identical to mine same OS etc and his works fine, at some point he may want his back and im afraid to go buy another lap top just for this thing only to have it do the same thing a week later ya know? its really weird, and like i said mine worked fine for about a week and then one morning it just wouldnt connect anymore, im not really sure what to do from here…

Really sounds like you did all the right troubleshooting

I would save all your files on a flash drive and do this factory reset myself before going and buying new computer.

1 Like