Crossfire legacy mach3

Yeah tried to download the post processor for fusion and it’s the same one thats installed , just downloaded fusion this weekend.

Also I have tired other programs (qcad , autocad)to make files and then sheetcam (with mach3 no z selected)and also lazycam to do the tap files.

And all say same thing in mach3 when they have a round edge or circle in it. "Radius arc not at same point ect"and won’t show the preview of part on mach3

So I was thinking it was a mach3 issue possibly cause of multiple programs doing it.

I was going to try and reinstall all programs tonight maybe

Can you post the generated program?

Howdy Brian… I remember this error from a ways back…

A quick search shows me this------>

Open Mach3 and go to Config>General Config and change the IJ mode to Absolute. Reload the file and it should load without that error message.

EDIT: So this fix above proved to be wrong… Should have stated to change IJ mode to “INC” not “absolute”… User now has a working system!!

this is my mach3 general config

here is what i had selected in fusion for mach3

this is same number as the fusion download page

top half of the code for a just a circle from fusion
and you can see no preview in box

2nd part of code with radius warning in bottom box

but i can make a box with a square and a triangle in it and it will preview and the cnc would follow what fusion shows me also

Rats!! I thought that would have done it… Try adjusting your initialization string to look like the one in the following picture…

This seems to have worked in an earlier post by @john543 here:

I’m not running Fusion or Mach3 any more but, I do think I had to do this also… It sounds very familiar…

Also, when starting Mach3 do you get the option to choose the Crossfire Profile like below?

yeah i have the crossfire profile loaded , asked me when you open, and i deleted the rest to make sure i didnt pick wrong one later. shows in the bar on the screen also.

tried adding the G91.1 no change

wonder if i should wipe mach3 off computer and redownload

Might not be a bad idea…
Plus, I’ve just been going off of memory here… I know there are still some Mach3 people around… I wouldn’t give up hope just yet… I’m sure they will chime in here eventually…

post the gcode file here and someone can try running it on their computer. Cletus still runs mach3.

OHHH… @Cletus …are you out there…some old fashioned Mach3 question for you here…

I think you should try wiping Mach3 and reinstalling it. Can’t fathom why it’s doing this.
That said, I do not use conFusion360, I use AutoCAD 2007 and I post process in SheetCam. It may also very well be something daffy in Fusion360’s post processing.
Meanwhile I will sleep on it a bit.

My Mach3 General Logic Config is exactly as yours is, except that “G04 Dwell in ms” is selected… still looking, things like this keep me awake at night :crazy_face:

Actually two differences:

Sorry I guess new members only get 15 posts a day. So I couldn’t get back on last night

I removed and reinstalled no change.
I added the G91.1 bak to the line in the configuration. No change.

Then changed Ij to Inc and it all works now…

I was cutting stuff last night but couldn’t let you guys know!!!

1 Like

That’s great news!!! Thanks for hangin’ in there with us… Sometimes, it’s just the littlest things!! :crazy_face: :crazy_face: :crazy_face:

1 Like

GREAT NEWS! :rofl: :beers: