Continuity Issue

i found out thru the tch link that i have continuity between the usb sleeve and the torch gantry (4 and then 3ohms) after snugging down the box to the table leg. Was going to send them an email for the fixes but figured with the holiday i’d try here to see if anyone else has worked thru this simple issue that I still cant figure out. I’ve even tried taking the box off the leg entirely an the ohms went to 14+ so that isn’t the fix- haha! the confusing parts is that when doing the first quick test cut everything worked fine and cut pretty much perfect. after moving it into a better location right after is when i lost comm with the torch. I can’t even to a test thru fire control. everything else works and communicates fine.

everlast 62i, machine torch, hard wired to plug langmuir provided, no splice or T tap- soldiered in correct points of plug


Did you use the isolators between box and leg of table?

i did and they are in. i just saw in another thread about same issue that my continuity is good. zero when plasma off and continuity when plasma is on. was going to check the boards inside again that they are all the way in since that was the other guys fix? i even added larger plastic washers inside the box and still wasn’t firing.

seems like a simple ground issue but cant find where else it would be. ha

Isolate the ground plug on the computer.
I used a old school plug adapter and the problem was gone.

Eaton 419GY 15-Amp 125-Volt Single Outlet Grounding Adapter

1 Like

thanks, i found the issue- installer error- had the red/ blk from cnc flipped. ha i didn’t print the download from the card (50 pg but much more info) and went from a diff place. i don’t think it specified that red was neg. oh well- now i’m trying to get the thc activated. its cutting very nice once speed dialed in for demo steel.

1 Like

Im having the same issue. im getting continuity from langmuir control box to table, i have the plastic washers and spacer bar on the back of the control box. when you say had the red-blk from cnc flipped what are you exactly talking about?

Red wire goes to work piece . Black to torch lead.

Is this what your talking about?

No thats a micro switch for THC. The VIM black box on plasma cutter .

No. That is the IHS switch wires. He’s talking about the voltage wires from the plasma cutter to the VIM box.

1 Like

so i have the hypertherm plug and play connectors, hopefully im following you guys well.

The other end plugs into torch port on Langmuirs control box.

yes the other cable coming out of the VIM box is plugged into langmuirs control box.

Yes. Double check all your connections with the instructions :wink: Make sure the black VIM box is connected to the correct port.

this is how i have it hooked up. but then i do my continuity test and i have 3 to 4 register on my tester

The continuity that matters is between the USB shell(metal around the USB plug) on the control box and the table. Do you have a laptop stand bolted to your table? Those are another source of continuity between the computer and the table.

1 Like

Ohm reading is something totally different . The table chassis is getting a connection to your control box. Make sure your isolation bushing is installed correctly.

Yes i have continuity between the usb shell and the table. i do not have my laptop hooked up to the table

I have checked my plastic isolator to make sure they are pushed through the holes on the control box and i have the plastic washers on the inside. they are snug tight shouldnt be making contact through there.

1 Like