Boss Probe error latest CutControl (FIXED)

Today I finally installed the latest Cutcontrol and firmware update.

I was excited to run the Boss Probe routine, but I kept getting the same error, no matter what I tried.
I set up the probe at 9 o’clock as suggested and as soon as the first touch is sensed, the machine stops with this error:

“G-code motion target exceeds machine travel. Machine position safely retained. Alarm maybe unlocked.”

I made sure that the estimated diameter was similar to the real one and the clearance was properly set, but no luck.

Also I noticed that to clear the alarm, you need to press “soft reset”. “Clear Alarm” will do nothing.

ANYBODY has a suggestion?


UPDATE: it turned out that to measure a 0.7” diameter boss, I had to set “ boss diameter Buffer” to 0.2” instead of default 0.5”. I am guessing this is the extra diameter the probe will extend beyond the set diameter. Not sure why the 0.5” would trigger the error, considering the max seek distance is set to 3”. Can anybody explain? Thanks.