Bore probing issue

Hey guys,
Trying to probe a bore and when i go to start i get an alarm that says g-code motion exceeds machine travel.
The only way to clear it is to shut everything down and when you start it back up you have to turn off the limit switches and then raise it up, turn the limit switches back on then home it. Has anyone used the bore probe routine at all ?

Update: a work around is to turn the limit switches off and probe. I was terrified but it worked flawlessly .

Its worked perfectly for me. I’ll run a test in the morning and see if I can help.

If i turn off the limit switches, i have no problems it works perfectly. Not sure why but i just ran into a huge bug i ran a drill toolpath and my machine went to max height when it finished and hit the z limit. So i lowered it down (no big deal) it prompted me to home machine so i did. But none of my limit switches worked i double checked they were all on and nothing. The machine would just try untill eventually it would say it couldnt find y limit switches. After nothing would work i re started everything got it all away from the switches and tried re homing. Same issue. Next i tried homing using my laptop instead of my touchscreen and boom works perfectly. Im starting to wonder if theres some issue with my pc controller and not the machine

@Jpersons44 We are aware of the bore probing soft limit issue. It will be fixed in the new release of CutControl this week.

Also, anytime you might suspect a limit switch issue the best way to troubleshoot is to make sure that they are enabled, and then go one by one and cycle the limit switch and make sure it is showing as triggered in CutControl. So for example, to test the X limit switch, click the switch in by hand and then release it. Then go to CutControl and clear the alarm. This will then allow you to see the status of the switches at the bottom when you click them. Then go cycle the X switch and watch in software and see if it is lighting up when you push it in. Then do the same for Y1, Y2, and Z. It’s possible that you have an intermittent wiring issue (e.g. blade connector not fully seated) that needs addressing.


Just double checked everythng didnt see any issues pulled the enclosure cover off and checked all connections. It was a very weird instance. Nothing was reading. When it happened the first thing i did was test all the individual limit switches and none of them would read. But the hard limit alarm would still come up. But i wouldnt get x or y limit switch alarms. Even after multiple power cycles. It was very odd. I finally decided to use cut control on my laptop and then everything started working again. Thats why im wondering if the mini pc was just totally lost or something?

@langmuir-mike NEW CUT CONTROL?!?!?

Any chance you could share a list of what has been updated so we know what to expect?


Any news on will this will be fixed?

I think we are experiencing the same issue you are describing. Homing sequence won’t activate the limit switches but we can touch them off and they software sees them being pressed. Did you ever come up with a cause/solution.

if I remember correctly I believe there is a way to re-flash the firmware via cut control. I did it from my laptop though not using the mini PC, Hopefully that helps I wont be home to look at it till tomorrow but i can update you more then.