Big time lag when jogging

I open Fire Control (21.1.5 compatibility version) and then turn on the electronics box. I then try to jog the machine and there is a 2-5 second delay between the time I press any jog direction button to the time the stepper actually begins moving. I then cut off the electronics and close Fire Control. After deleting my Fire Control User files I can re-start Fire Control, turn the electronics box back on and everything is normal with no lag. Also, it makes no difference if my laptop is running on 110V or batteries. This happens every time I cut the machine on.
I have a suspicion that one of you guys knows the answer to this issue. I did a lot of looking on the Forum for the answer but I never found any definitive fix, although I did see that others had the same issue. I did contact support.


Only spot balling here ,Some kinda of memory issue maybe? RAM issue?

Does it happen every single time?

It will happen until the User files are deleted and Fire Control is re-started. After that there are zero problems. Not sure if it makes any difference but the laptop I’m using has 8 GB of Ram. I would think if Ram was the issue it might be an issue on every startup. Thanks for the reply.

It may be nonsense what I say, but have you tried uninstalling and installing the software? maybe doing that will solve it

Not nonsense at all. I reverted back to an earlier software build (per a conversation with Support) and then realized I needed the current build because of limit switches so I reloaded the latest version again and the problem went away for the next 5-6 on/off cycles. Then it came back. Not a deal breaker but kind of a nuisance anyway. Thanks for your thoughts.

Hey James,

I was the one helping you in your tech support ticket earlier, I’m looking into this issue and will let you know when I have any potential fixes that you can try!

Thank you for keeping an eye out. I appreciate any help you can give.

I’ve had this exact same issue since I started using my Pro in November. I sometimes have to close and re-open 3-5 times before the jog function does not have a lag. I’ve tried multiple versions of FCtrl and every EMI countermeasure known.

If I try to use my machine BEFORE resolving this issue, almost every time Firecontrol will freeze up during the cut. Usually the program continues to run, but all controls and the visualizer are frozen until the program completes.

Dell Latitude, core i5, plenty of ram…

Good to know it’s not only me having this issue. The weird part for me is the fact that I can delete my Fire Control user files prior to opening Fire Control and I won’t have any issues throughout that session. It’s a crapshoot when I close and re-open FC on whether it opens correctly (without the lag) or not, but, for sure, if I delete the User files prior to opening FC I won’t see any issues. Thanks for sharing your experience.

1 Like

one thing to look into arte any background processes running while trying to run Firecontrol…
next is ferrite chokes…and then make sure no wires are coiled near the control box or near the USB…

1 Like

Wires have no coils in them. I’ll check for background stuff running. I didn’t install any chokes but I’ll certainly check to see for sure.
Thanks for the help.

I always cold start my laptop, with WiFi off and don’t open anything but FCtrl. It happens with only the controller and laptop running. Cutter is off. I have gotten to the point I can tell just by watching the speed at which FCtrl opens when it will work okay and when I’ll need to restart.

I’ve got 12 chokes in place, with 2 on the USB to the laptop.

I am getting another laptop from a family member in the next week or two. If that doesn’t resolve the issue, I will be opening a service ticket. I’ll feel like I will have tried everything on my end.

It’s nearly 100% of the time though, if there is a pause in my jog function when FCtrl opens, it will freeze up during the running of the G-Code, then release 5-10 seconds after the program finishes. I don’t even try anymore. Just close and re-open until it works correctly. Then it very rarely freezes.

You have described this perfectly. I noticed today that when the initial message comes up about ‘what’s new’ or something like that and there is a lag in closing that document then things are not right. I do wonder if there’s something in the User files that’s causing this because as long as those files are deleted prior to starting FC everything works fine. I owned a Dynatorch about 10 years ago and they stipulated that you could only run their software on a desktop (laptops like my current one were not allowed) and I wonder if there’s something to that also.
Thanks for taking the time to contribute to this, maybe it will attract someone’s attention who’s smarter than you and me to figure this out.

1 Like

I had this problem with a Windows laptop that while I thought would be sufficient its graphics card was not if I ran the visualizer. If I deleted the user files it might be ok for a minute or ten but eventually returned to this lagging state. If I turned off the visualizer it worked normally. Try turning off the visualizer and see if that changes what happens.


Yep, that is exactly what is causing my problems. As soon as I cut the visualizer off the lag goes away completely. I thought the ‘compatibility’ version of FC was supposed to address this issue?
So, the question is: Do I continue using your workaround of just cutting the visualizer off or is the only other solution to go out and buy new hardware that is more compatible with the FC ‘compatibility’ software?
Thanks very much, Scott. This really helps.

The workaround sucks in my mind, I couldn’t work that way I like the visualizer. I had a Macbook that I had recently replaced laying around so I use that. I would say you’ll need to upgrade in order to avoid the problem. I was never able to make the compatibility version work except by turning off the visualizer.

It didn’t do any good for me either. And I agree with Scott, I use the visualizer too much to disable it.

All good points. I also want the visualizer on but I hate to go out and buy another laptop not knowing if it will work or not, which, BTW, how would I even check to see if the graphics are OpenGL 3.0+ compatible?

Thanks for the help.
Sucks a lot.

I agree with the sentiment that disabling the visualizer is a band-aid, not a solution. I’m looking into this!

@metalcrafter whether or not a computer support OpenGL 3.0 or higher is generally not listed in the computer’s specs, but details about its graphics card is. If you have the graphics card model, you can visit the website of the graphics card manufacturer (NVIDIA, AMD, etc.) to find detailed specifications and supported OpenGL versions for that particular model.


I appreciate you looking into this. I believe you’re 100% right that the graphics information you need to run FC is available for most desktops that can run a standalone video card, but I’m not sure how to find a graphics card model for a laptop (like most people here are using). If they’re not high end gaming laptops I think the graphics card is integrated on the motherboard, isn’t it? So, do I now need to buy a desktop to get your software to run correctly? I’m thinking probably not, but what published specs in particular am I looking for that will negate this issue before I invest in even more hardware?
Thanks for paying attention to this issue.