Anyone else having problems? - Z-Axis moving up or down with inactive THC - SOLVED

My torch keeps raising on the last outside cuts. It goes up like half an inch. I feel like the last few updates have made the machine worse. Everything seemed to work so much better when I first got this table and now Im just blowing through comsumables from these updates and wasting material. Yes dry air. Yes brand new consumables for the 3rd time this week. Yes its the correct pressure. Again this thing worked almost flawlessly the first 3 weeks I had it and now these updates are making it worse. Anyone else experiencing this.

I use Sheetcam and Razorcut 45. Hex 1.07 and Sheetcam plugin 1.4

Sorry you’re having issues! Can you post your .tap file for this cut? There should no longer be a missing H0 (THC OFF command) in the post which should have solved the issue of the torch rising.

Here you go

1 current.tap (31.8 KB)

I’m not one to complain, but I have the exact same problem going on. THC will work normal for any cut that lasts less than about 5 seconds. After that, it rises steadily until it’s an inch or more off the steel. I have become fairly frustrated and just turn the THC off manually for the last cuts. Doesn’t matter if I’m running FineCut or regular consumables. Doesn’t matter if I run 45 or 85 amps. Oh, and for some reason my voltage is always in the 40 to 80 volts range, even though the book says 130 volts…

1 Like

We’ve been unsuccessful in replicating this issue in our shop. We have been population testing motion control boards, THC’s and VIMs(connected both raw and divided) to try to isolate which of the three could be responsible and we have not been able to see this behavior even after testing 50 of each component.

With that said we have a basic hypothesis. We do know that coupling USB ground to the machine frame has a drastic negative impact on live voltage reading and thereby THC performance. We have seen on our set up that if you have continuity between USB ground and the machine frame, the voltage drops from 110-130 all the way down to 20-50.

Also just to be clear you are using V1.07 of the THC firmware correct?

The first thing I would recommend checking is continuity between the USB ground and the slat bed while the computer is plugged into the Electronics and resting on the laptop stand if you use one. If you don’t have continuity their, it would be immensely helpful if you could screen record FireControl while the behavior is happening so we could see what the THC is doing.

1 Like

Im running 1.07. My continuity is fine. I have triple checked. Like Joshua said on long cuts is when the thc raises. I want to roll back the software but dont remember which combination was the best. I know it all worked great about 2 weeks after i assembled the machine. My voltage dropped 2 updates ago but with the newest updates im in the 116-130v range.

Are you using sheetcam?

No, I’ve always used Fusion 360. I do all dimensional drawing…

Ok so that should rule out a sheetcam issue

Would either of you be able to get a screen capture showing FireControl when this is happening?

I will try today

Do you have the THC speed threshold set to 85%? That’s the default.

yes 85%. everything was working so good a few weeks ago. I had a few issues before with losing the arc and having to “start from here” randomly, but i could deal with that. I never had issues of the torch randomly raising until you guys did the update for issues people were having of the torch randomly raising. When the torch raises it goes up and doesnt lose arc. Just shoots a whitish purplish ( i think i have shade 5 goggles on) long arc around the rest of the cut. I will try and get a video later. Homeschooling 3 kids. Its tough to get time lately

@dj_elite we were able to replicate this issue using your cutting file; we are working on a fix stay tuned!


glad to hear im not going nuts! lol

1 Like

Thanks to all of you for your patience while we tackle these problems.

There were two issues that combined in @dj_elite’s program to cause this Z running away problem. Others may have experienced this issue differently as unexpected movement of Z up or down while THC was not in an Active state.

The first is related to the SheetCAM POST. The above program is posted with a PS value of 120 while the feed rate of the program is F100. This is due to an unforeseen issue in the previous versions of the SheetCAM post that allowed previously posted programs to clobber the PS value of later programs (in the same SheetCAM session) if the feed rate of the later posted programs was lower. This is likely why this program shows a PS120 while the feed rate is now 100. This clobbering issue has been resolved in V1.5 of the FireControl SheetCAM post.

FireControl - SheetCAM Post V1.5

This problem disappears if the correct PS100 value was posted or if one were to lower the Torch Speed Cutoff value to less than ~80%. The default 85% of the PS120 used is a feed rate of 102 which is only seen (and thus THC Activates) for quick blips in the corners (when sending steps to both motors) as the straights max out at F100. Most of the program as posted did not have any Active THC while running. WIth an Active THC for the perimeter cut the module accounts for all motion and doesn’t rise or fall.

The second issue at play here in the THC Firmware (all previous versions) was caused by these mishandled blips of THC activation. These quick Active THC blips caused stack up errors in the step counters used to move the Z axis while in THC control but not active. This issue has been resolved in the latest version (V1.08)

LS-THC V1.08

We understand that keeping track of updates like this is difficult so we are adding firmware update notifications to the next version of FireControl. You will be notified when you have updates available to be installed when your machine connects.

Let us know if these updates solve this problem for you. We successfully cut multiple of these programs out with your code as written (PS120).

Again we thank you for your patience and help in finding and fixing any issues.


Awesome! Your customer support is the #1 reason I purchased this table. I appreciate the work you guys do, especially in these tough times. I will update and do some cuts tomorrow


Me too on the customer service part. I was getting a little nervous at the top of the page, I feel a lot better now. I’m in batch 2 and excitedly waiting for my machine to arrive this month.

1 Like

Just part of being batch one. Got to fix all the bugs


In my case the UP indicator was lit while the Z axis was climbing. It would only do it on long straight cuts on any thickness or amperage. I will flash the new firmware…

1 Like