Alternative pendant (wired)

Not sure how many here are involved with the Facebook group, so I wanted to share this here, as I’m pretty impressed with this little device (unaffiliated with the maker):

To continue the discussion of an earlier post regarding the wired pendant/keyboard emulator… I’ve been able to hook mine up and did a little reconfiguring, and I love this thing! Unfortunately, cutcontrol has only a few keyboard shortcuts, however, the joysticks work great for jogging all 3 axis, the start/pause/stop buttons work as expected, and with the small changes I made, I was able to make the “mode” key emulate the “tab” key to change jog modes. And in the “step” jog mode, when you hold the joystick for a short period, it runs in continuous steps until you release it.

If anybody decides to pick one up, I can walk you though modifying the mode button with the code I used (or help a little with setting up your own changes), it’s remarkably easy, but you do need to download a simple program.

eBay listing:


I did pick up one of these pendants. If you don’t mind sharing the code it would be much appreciated.


Connect with PuTTy, then paste everything below into the console window.

:11,\M3,\09,\09,\K@; MODE SELECT
:31,\M3,\09,\09,\K@; MODE SELECT
:51,\M3,\09,\09,\K@ MODE SELECT


Fantastic. Thanks for the information.

1 Like

After pasting your code in and testing the button, I noticed it was putting an extra “” as well as tabbing. This code seemed to do the trick with no additional characters:

:11,\M3,09,\K@; MODE SELECT
:31,\M3,09,\K@; MODE SELECT
:51,\M3,09,\K@; MODE SELECT

I think the issue was using a “” with the numeric value of the keys. Also you had duplicate entries per line which was tabbing multiple times.

I also setup the home button to home the machine using:

:13,\KA,h,\P1,\Ka, ,\K@;
:33,\KA,h,\P1,\Ka, ,\K@;
:53,\KA,h,\P1,\Ka, ,\K@;

The tabs are intentional because of the order cutcontrol tabs through it’s jog modes, I set the mode button up to correspond with the modes on the pendant AND cutcontrol.

In cutcontrol, with rapid set… The first tab goes to .001, the second goes to 0.010 and a third back to rapid.

On the pendant, with mode starting at fast, the first press goes to slow, and the second goes to step, and the third goes back to fast.

The new configuration starts cutcontrol in rapid, with the mode set to fast. One press of the button changes the mode to slow, and double tabs cutcontrol to 0.01, second press sets mode to step, double tabs cutcontrol to 0.001 and enables continuous stepping of 0.001 steps.

fast = rapid
Slow = 0.01 steps
Step = 0.001 steps with continuous option

The code works perfectly for me, and I had zero issues. But if you get cutcontrol and the pendant out of sync it won’t tab as expected. You need cutcontrol set to rapid when you plug the pendant in, then when you press mode button, 2 tabs gets you to the .01 steps, 2 more gets you to .001 steps, 2 more gets you back to rapid and all the modes and lights correspond.

I’ll have to try your homing code.

I’ll have to give your code another test. It was behaving weirdly for me. Maybe I was just expecting different behavior. I updated the post with better code for homing. If you adjust the \P1 you can extend the delay before starting to home. This could be a fail safe in case the button is accidentally pressed.

I should have explained the intent better so you’d know what to expect.

I had a chance to test your code again and after reading through your description it makes sense. I would be nice if there was a hot key to adjust job speed. Maybe one day.

Taking the “” off of the 09 in the code cleaned up the extra characters. I ended up with:

:11,\M3,09,09,\K@; MODE SELECT
:31,\M3,09,09,\K@; MODE SELECT
:51,\M3,09,09,\K@ MODE SELECT