60i raw voltage

I have been using a 60i to cut. Sometimes it would bug out and dip low and drag the tip on the material. I figured it was something I’m doing but I’m Im convinced it’s not. I did the thx test and it fails saying the voltage is too high. I have been messing with it and can not find a good place. I have tried hooking up to the j609 ports to no avail. Anyone have they 60i hooked up manually?

welcome to the forum…
the 60i you have is that an everlast plasma unit?

I guess I should have been more specific. It’s the Thermal Dynamics 60i

ok…some basic rules to follow

  • do not have laptop plugged into a charger when you are cutting or have it on a isolated ground plug
  • make sure the clamp is on the material and not on the slats or just in the water…needs to be on the metal
  • if your table is dirty…make sure the contacts on the THC are cleaned regularly

Hey, I don’t know if you figured it out or not, but I was having the same problem with my Everlast 82i, and after a lot of testing, I removed the usb isolator and run some test,and problem solved. My machine have de cnc package. . I even tried with a piece of metal to raise the material on one side ( in 16" distance like a diference of 1 ½" ) and still cut good,I raiced the voltage more but did the trick.
Hope this can help somebody

1 Like

@Cooper Good Morning and Welcome to the Forum.

Thanks . Just trying to help :grin:

1 Like