Y Axis randomly not working

To make it short and sweet, everything worked this weekend, shut everything down, went to go use machine today, Y axis would not jog by arrow key in mach 3, or move if Gcode was started.

Things i have done:
-swapped cables, stepper motor works on both X&Y
-restarted everything
-browsed the forums
-drank 4 beers
-tried everything again
-made an account cause im tired of getting my ass kicked

I have a water table, i have a weird suspicion water may have gotten somewhere it shouldnt have. I popped the cover panel off, everything appeared ok, as far as i could tell, voltmeter is at a friends house, so i couldnt test voltages. What i did notice however was the lights on the stepper driver boards. Both have a green and blue. My x axis has a solid green, with blue lighting up barely when the axis is jogged in mach 3. The y axis has solid green and solid bright blue (trying to upload a picture, first post though, so we will see how that goes).

Picture in my google drive - https://drive.google.com/file/d/1OqDWRBgGbzJh96AAaHGPsrXFON3uYFf1/view?usp=sharing

Im just wondering if water got into the plug in somehow and shorted something out. Any wiring diagrams to check voltages, or thoughts to go from here are greatly appreciated.

Thank you, Chase

I’m not sure what this means exactly. When you swapped the cables, does that mean that the X jog DID move the Y stepper and the gantry moved?

Maybe should have done this second and then had the beers while you waited for an answer :wink:

If the answer to my question above is yes, I’d vote for one of:

  1. there is a loose connection between the CrossFire controller board and the Y Stepper Driver, or,
  2. somehow the current switches on the Y Stepper driver got accidentally flipped (should be set for 4Amp current), or,
  3. the Y Stepper motor driver is shot (you can find these for about $12-$18 on Amazon, look for TB6600a Stepper Driver (Amazon.com)
1 Like

It should be under warranty if it is shot. Langmuir should replace it. Just needs an email to Support.

1 Like

Good point, in a case like this it helps to include @langmuirsystems in the posting.

I have this weird feeling the motor driver is shot. I swapped cables to verify all motors were working to rule them out. Like i said, everything was working after I shut down this last weekend. Im more than happy to test a few things to determine the true issue so im not throwing parts at it. Ive had the machine for over a year without issue.

1 Like

Well, I have installed a new stepper motor driver still having the same problem, contacted support (still have not heard back). I am wanting to trouble shoot anyway i can. I figure i should be able to test voltages to trace where the break in communication is. Would anyone happen to have a break out of what i should be seeing voltage wise coming from the controller board, and output from the stepper motor drivers? Really need to try and get this up and going for a project that is closing in next week, and for christmas presents i should have already been working on.

If you were using a wireless keyboard check your batteries same thing happened to me a while back with a wireless keyboard

Dude, I wish it was that easy. It is connected to my laptop. Using all of the langmuir supplied cables.

Just be a while to figure it out LOL never gave it any thought…

Chase, you mention continuing to trouble shoot. Would the fastest answer come from lifting the inputs from the motion control board that go to Y axis and placing those inputs on X? Tell the motion controller to move Y and then X should move. If X moves the motion control board and its connections are good. Should X not move the problem is in the motion control board or its connections.
Moving the inputs from bad Y to good X saves you from needing to know voltages and signals.
I included an image of a modified CrossFire. I have a CrossFire Pro. I put green boxes around areas just see where a problem could lie based upon your comments.


Well, I got everything working last night. Stepper motor driver was at fault. Turns out it really helps to replace the axis that is having fault, not the one that is working… One of those dumb things i never want to admit happened, but just in case anyone has a similar issue, always helps to have an answer to the problem. I purchased the stepper motor driver shown in the link, and that worked once installed into the correct axis… Also, for anyone dealing with the same problem, verify motor cable is connected once stepper driver is installed, because it still isnt going to work if it isnt connected… Last night was one of those where I face palmed myself from my own stupidity, but was overcome with excitement when everything was working. I appreciate everyone’s help!! Excited to be up and running again!!


Went to do some cutting this weekend and the stepper motor driver i bought appears to be overheating or something of the sort. It will run just fine for a minute then cut power, lights shut off and just a hint of the blue light is visible. Shut power off to the machine, turn it back on, and everything is back to normal, for like a minute. The driver is considerably warmer than the other one, heat sink it came with was about half the size as well. Went on amazon, going to try the one in the link below.

is it a fully compatible driver?
I would tend to think by the description it is not compatible…check with the boys at langmuir

The boys at langmuir have been a little slow at getting back to me, from everything ive looked at, it should be an upgraded board from the TB6600 boards we have. Going to give it a shot, worst thing to happen is I have to wait till february for the pro :wink:

I am just curious what is the condition of SW1, 2, 3 and 4 on the stepper motor driver? I notice the side image of the switch has a table of current values based on SW1-4. You mentioned possibly overloading the driver. The switch positions could affect the driver’s allowed duty cycle.

That driver is far better than the ones that came with CrossFire. Just be sure you set the switches based on microsteps and Amps, not physical switch positions.

Update for everyone! Got the new driver installed, works great, going to order another for the other axis. They are bigger than the other ones, so i will have to do a little bit of case work to make them fit. Might 3D print some parts to help. There is a setting in Mach3 that needs to be changed. Below is the description of what changes. In my opinion the driver takes away the grinding noises and is smoother running than the stock ones. Linked below that is a video that will show the setting change to allow everything to run the way it needs to.

First thing is first. If you swap the standard board for this you will notice your jogs are reversed. I did not change any direction wiring to see what that did. I went into Mach3 and changed the following. Go to the upper tool bar, select the Config tab, go down to the option that is Ports & Pins and select it. A window should open that will have a few tabs to select. Find the one that says Motor Outputs and select it. It will bring up a table that shows all you axis. Find the axis you swapped out the TB6600 for the DM542T, then under the Dir LowActive tab, change the green check mark to a red X/crossout. Make sure to hit APPLY, then hit OK and the window will close. At that point, you are done and ready to go.

In the link below is a video which shows this. He shows how to at 7:50 into the video.

Hope this helps anyone in the future!!

Is there any sound? I found my stepper motor coupler set screw had vibrated loose and things stopped moving, but I could hear the stepper motor spinning. If you have sound, take a light and look closely at the motor side of the coupler. Good Luck.

Having problems with mine since day one. I think narrowed it down to the Y2 driver. But I have no experience with electronics. Getting extremely fed up with this machine. Almost a month in and yet to make a single part, and if I hear motor couplers slipping again I might implode.