Y axis, not full travel?

I have the Crossfire working, and have made a few test parts. However, I have an issue with the Y axis movement. If I jog the X axis, it will go end to end, full travel. But, when I jog the Y axis, it only goes about 80% of the way. With about 4"/5" of travel not used. I’m guessing it must be something simple, but I have no idea.

Hi Brian, if you loosen the lead nut screws will it jog all the way?

good evening Daniel my Y+ axis is having the same issue

I found a previous post that discussed this same issue with a/an explanation to repair and it seems to be running the break in program just fine. However each time i start the breakin program the y+axis crashed into the Y axis mounting bracket on its first run down to the Y+ end of the table.

Hi, it could be that your Y 0 coordinate location was not close enough to the stanchion plate, so it simply crashed into the stanchion plate on the other side. Not a huge deal. As long as it runs all the way through you’re good to go.

Thanks Daniel. I’ll check to make sure of that by using a gauge block the next time I go to zero the machine and run the break in program again

Ok guys,
I just fixed my Y axis issue. The stepper motors have a certain rotational limit. So, when it only goes to a certain point, not all the way across the axis, you have hit the max point.
Here’s how I fixed it:
Go to the max point of either axis, then unscrew the lead screw assembly from the axis, 4-10 x 32 allen screws.
Slide the axis to the max point on the rail, less say about 1/4".
Then hand screw the lead screw assembly back to the axis mounting point, reassemble the 4 - 10 x 32 screws.
At this point it should be fixed. I ran the X / Y axis back & forth a few times, & used the Mach3 program to get back to the zero origin point a few times. It took 2 or 3 time for the machine to get happy with it self.
If your not completely sure how to do it, 262-384-1266, cell, day time, 10:00 AM / 4 PM

1 Like

Well apparently this issue still exists for me

I verified my lead screw was centered in the assembly, and followed the instructions of Brian two to three times. The motor is also traveling less distance than it was before when it locks up. I have a video of what its doing however I receive this message when i attempt to upload it

Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, svg, dxf).

My thoughts are that it may be something else since it is locking up in both directions now

Please let me know if there is some way to possibly share a video to an email

If you run the Y axis + as far as it will go, then disconnect the lead screw actuator. Move the Y axis to the end, and then screw the actuator to it. I gave up trying to use a center point. Are you saying this will not work? If so, the stepper motor may be faulty.

Flip the leadscrew and see if the problem follows suit.


Should I rotate a full 180 degree ?

Pull the leadscrew completely out and flip the leadscrew end for end then reinstall it.

Make sure you mark the leadscrew somehow or measure from one side to the problem area where the lead nut gets stuck. Flip the leadscrew and run a test. If the gantry gets stuck again measure from the leadscrew end that you measured from before and see if the nut is in the same spot on the leadscrew.

1 Like

Hi, we are working on a troubleshooting guide to address the binding issue that folks sometimes encounter. That should be posted this week.

In the meantime. please loosen the four lead nut mounting screws and attempt to jog the machine. If it still hangs up then it is an issue with the lead nut and we need to send you a new one.

If it doesnt jog even with the lead nut loose, let us know!

Good Morning Everyone

Update as of 1/28/19 AM A full rotation of the lead screw 180 deg. and running the Y Axis all the way to the end of travel towards Y+. I reassembled the lead axis I just barely let the lead screws kiss, leaving them loose and proceeded to manually run the machine back to Y- axis to zero it out and begin again it stopped yet again. However if i keep my hand on the lead screw and actuate the release the machine runs just fine and does not hang up.

to be more specific i hold in the spring that puts tension on the lead screw

Do you have grease on the lead screw?

Yes I do. What type of grease are you shipping the units out with? Just as an FYI to myself and others.

Hi @artfish71,

From everything that we’ve heard on this thread it’s sounding like your lead nut threads could be a bit tight which is causing intermittent binding issues which tend to happen closer to the end of lead screw travel where the lead nut would be most constrained. We had a small quality issue with our lead nut vendor awhile ago that’s since been solved but some folks could have gotten lead nuts that were tighter than normal. Please submit a ticket to our tech support team online at http://www.langmuirsystems.com/contact and we will get you out a new lead nut ASAP!

I am using 3-IN-ONE oil. Old timers use to call it sewing machine oil.
Lowes, Homedepot, amazone