XR X axis gantry binding problem Help

I am having issues getting my X axis to travel at 400 IPM. I have been through the alignment and tightening procedure countless times and nothing seems to solve the problem. I did have it working for a brief period to cut 3 art projects that did not have critical dimensions. It was at slower speed as I was cutting at 100- 120 IMP on 1/8 inch. Now that I need to cut a bracket that needs be the correct and accurate dimensions, I can not get the X gantry to travel over 400 IPM reliably or jog between cut points without slipping and losing steps. It does seem to do Ok at 200 IPM when jogging and not cutting.

I printed my part on a 3d printer to have a scale part to check how the machine is working. I zeroed everything on the corner that was defined as the starting point and pressed start. I am cutting 1/8 inch steel and have the cutting speed set to 100IMP but had it on dry run to test the program and make sure things are working correctly. Shortly after starting the dry run cut I can hear the X axis motor binding and losing steps. I can also see that is is not even close to following the 3d printed part I made. I stop the program and and have it return to the work zero and the torch is off in the X axis by over an inch.

Things I have tried and checked.

  • Realigned the ball screw and tension as per the video and directions
  • Checked the alignment and bearings on the carriage to make sure they are moving square and freely
  • Checked the big bearing on the X ball screw to make sure it moves freely
  • Lubricated the ball screw and rod
  • removed the felt washer to see if it was causing excess friction
  • The Y Axis was aligned with a dial indicator and is within a few thousandths of being parallel
  • Langmuir support had me check the power supply voltage and it was 36.2 Volts (Fluke 17B+)
  • I checked the set screws and the tightness of the pulleys and they are very snug. I also made sure the belt is not to tight and has at least 1/4 inch of deflection. It does not appear that the belt is slipping due to being to lose or binding from being to tight.
  • The software is up to date and running the current version

I have had this machine for about a year but have really only cut 3 art projects as I can not get it to run reliably in respect to the x axis. I have emailed support and they seem very responsive though email. I do have a day job and have not been able to call as the time zone differences and my work schedule. It is very possible I am doing something wrong and would defiantly appreciate any suggestions or things to try. I am familiar with CNC machines as I designed and built my own a decade ago but have outgrown it. My old one used a rack and pinion so I never had to deal will ball screws.

If it matters I am using Fusion 360 and Sheetcam.

Could this be a bad Stepper Motor or possibly a stepper motor driver? I used Gecko drives in my other CNC machine and have never had an issue with those parts.

I disconnected the ball nut from the stepper motor drive housing. Even with no load or the ball nut attached the stepper motor sounds like it’s stalling and stopping at 400 inches per minute. It seems as though it’s binding and the only thing I could think of is the bearing, the stepper motor, or the stepper driver has an issue. Any thoughts?

My XR X axis tube has tight areas
at each end of the tube, had to adjust carriage bearings to compensate for this no more binding at 400 ipm travel. I discovered this when assembled table pushed the Z axis carriage along gantry tube by hand before installing ball screw and ball nut assembly. (X axis travel) it would bind at each end but free along rest of tube. Bearing adjustments very touchy … no problems for past two years now.

I can not get the X axis to function at 400 IPM. I just replaced the stepper motor and I am having the same issue. I can grab the ball screw housing with barely two fingers and a very light grip and it stalls. This is with the ball screw completely removed. The on;y thing hooked to the stepper Motor is the belt and the other pulley that spins the housing that turns the ball nut. This motor has virtually no load on it at all and it stalls. Should the stepper motor be that easy to stop? I tried plugging the new motor in to Y1 and Y2 and it does the exact same thing. I also replaced the bearing for the ball nut housing even though if felt fine. I do not feel any resistance or binding. I double checked the power supply voltage and it stays at 36.2 volts even under load. I also tried changing the USB cord and that still did not make any difference.

Could this be a bad controller? anyone have any other Ideas in what to check?

Here is a video of what is going on

https://youtube.com/shorts/ziQidtrK7Mw?feature=share

Hello CWalthers - I am new here and doing assembly on an XR. I have a similar problem. My table gantry works fine at 200 ips, but will only go one direction at 400ips (left). Going right it stops and I get the exact noise I heard in your video. I’ve done a lot to try to resolve it and looking through posts I saw your issue and thought I would ask if you found a resolution to your problem?

I am still dealing with the problem. The best advice from Langmuir is that it is an alignment issue with the ball screw. I have aligned countless times exactly as described and it still does not work consistently. I can sometimes get it to where I think everything is aligned and it works only to try it again the next day and it binds up and wont work again. Some things that helped is to spray down the ball screw with silicone spray and jog it back and forth to cover the entire screw, that seems to help but need to be applied before every use. Also, check the alignment of the stepper motor bracket in the attached picture. Mine was not installed squarely and loosening it and aligning the bracket made a small difference. I also noticed the belt gear had a lot of runout on it and I believe it was adding to much tension. I ended up 3D printing a new gear and it seemed really smooth out the belt and rotation of the gear. the belt also seem to mesh better with the new gear. I also removed the felt wiper as it seems to add enough drag to cause problems. When it is working it only takes a gentle tap of my finger on the ball screw housing to cause it to bind. I have some other ideas on some changes that I may implement. I will update if I find a solution.

image

Thanks for this info. You have given me a few more things to attempt. Appreciate any updates if you make more progress and I will do the same.

I just watched the video. Is that a new motor making that noise? There is no way you should be able to stop that with your finger. If that is a new motor take the old one apart and see if you see anything.

Does not make any difference how the gantry moves if you can stop that motor like that.

1 Like

The stepper motor is the original stepper motor. I replaced it with another motor and it did almost the exact same thing. I put the original back is place as the new one didn’t seem to improve anything and I didn’t want to redo the wiring all the the back. I have another CNC machine with NEMA 23 motors and they are very difficult to stop.

It seems the stepper motor is running at the very cusp of stalling. Even with just the motor and no ball screw, the motor just spinning, I can still very lightly tap the ball screw housing and it stalls out. It does not seem to make a difference if I switch it to a different stepper driver either. So without any load it still stops easily. That is why I do not think its an alignment issue but Langmuir insists that something isn’t aligned. I am not sure what else to check.

I checked the Power Supply voltage and It is at 36.2 volts, I just got a clamp amperage meter and I will try to check the amperage under load. I don’t know enough about the controller, but I am beginning to wonder if it is not providing an adequate signal to the stepper driver at 400IPM. I get the feeling I am not going to get much more out of Langmuir for help on this one.