XR Homing issue [Solved]

I having issues with my XR and homing. This is the my initial time trying and I keep getting errors.

First thing I would do is look back at the manual and check the adjustment on the limit switch’s


Did you get your homing issue solved? I’m having the same problem and have tried everything I know to do.

I had the x and y2 limits I’m the wrong spots

1 Like

If this is your issue, make sure you let us know and we can mark this thread Solved!

I have checked to make sure that the limits are correct. Unfortunately I’m still having issues. Checked my limit switch adjustment. Y1 will limit first, then I’ll move the gantry and get Y2 to hit first. I have re-adjusted the ball rails. Not sure where to go from here. Any advice would be appreciated.

So you are sure you don’t have the switches reversed?

If switches are correct go back in the manual and set the limit switches as explained there. Then see where your at

I had my helper hold each switch down to verify which axis they controlled. I have adjusted the switches several times but will try that again tomorrow.

My homing issue is fixed. I did check to make sure I had the limit switch placement correct and adjusted properly. I found that I apparently crossed my Y1 and Y2 cables at the electronics box. Human error on my part. Thanks for the replies. Made me go back and check the basics.

1 Like

Glad you got it sorted out; I labeled both ends of cables as I assembled my XR so I didn’t get cables crossed.