XR homing issue (SOLVED)

Having a homing issue with my XR was wondering if anyone else has had this and what the fix is.

maybe a bad switch or connection? have you tried tripping each limit switch manually to see if Firecontrol recognizes each?

I have not tried that yet but i will today

I don’t have an XR, but it certainly looks like the switch in your first pic is not closed. Either the two sides are not aligned or that bolt that trips the switch needs to be adjusted.

Yeah the Y1 switch doesnt touch when homing. I set them up the same so something is out of whack and not sure what it is.

Have you tried calling the XR support line? XR owners have a special support line for issues like this.

I have called and didnt get to talk to anyone. Im going to call them again today

1 Like

@langmuir-cameron should be able to help you out.

I hope somebody can. I just dont want to mess anything up

XR Phone Support

Crossfire XR customers are entitled to receive over-the-phone technical support with one of our Technical Support Engineers.

(936) 235-3991


If we are not available, please stay on the line to leave a message for our team.


I figured it out with Cameron. The X and Y2 limit switches were opposite so switched them and good to go.


glad you got it solved…I hope you do not mind I marked it solved…

1 Like