X axis scaling problem?

Hello again
Mike, K1FNX near Boston here

we got our new THC kit working tnx to TinWhisperer but when we tried an actual cut the Y dimensions were correct but the X were all truncated

I took an old TNG file done with earlier version of SheetCam, loaded it into the upgrade version of SheetCam and post processed it using the new version for Firecontrol…
agn all the Y dim are correct but the X are all truncated…

Firecontrol reports the correct X & Y extremities so it looks like Firecontrol is getting good info from SheetCam and I think when we jog 1" on the X axis it moves 1"

any ideas?

I didn’t start with a fresh DXF file and I wonder it that’s some of the problem

tnx and happy cutting

Mike, K1FNX near Boston

1 Like

Well, for that kind of problem, I’d go back to basics. Manually edit a GCode file, make a square, something you can measure accurately, leave the torch off, and just run the table through it’s paces, measuring the movements. I’d put G4 with LONNNNNNG pauses at each corner so you can measure it and observe. Try to use the same movement speed as your original file.

1 Like

tnx TomWS

we will run some experiments with simple basic shapes & files and see what happens…

before the THC/FireControl upgrade we were getting accurate cuts with QCad dxf files, Sheetcam G codes and Mach3 CNC controller.

agn, the jog distances seem to be correct (although needs to be verified) and FireControl accurately recognizes the X & Y extremes of the part

we will get there, we always do, you just don’t know how much pain it will take

tnx agn
Mike, K1FNX near Boston

Problem solved…we think

last evening we discovered that the set screws in the X drive screw were loose and therefor Firecontrol had limited inaccurate control of the torch carriage, not sure how that happened but it did

we will confirm the fix Thursday evening

I wonder if roll or cotter pins rather than set screws would be the way to go, certainly LockTite

will report back Friday morning

tnx for the help…great “community”

Mike, K1FNX near Boston

1 Like

I recommend simply grinding a bit of a flat on the lead screw at the coupler. I wouldn’t use locktite.

1 Like

tnx for the reply…we are going to add the expansion kit to our table over the next couple of months (end of budget year purchase) and will look at various alternatives, flats being one of them…too bad the motor end isn’t a hex…anything but round

tnx agn
Mike, K1FNX near Boston

Is Langmuir still sending out set screw couplers with the original Crossfire tables? My Pro table came with clamp style couplers.


not sure what you mean. To be 100% honest two of my “guys” were working that problem last night so I wasn’t that close to the problem/apparent solution. I believe what we have is a set screw in a coupler between the motors and the drive screws… I will look latter and report back

Mike, K1FNX near Boston

Didn’t know that, thanks. However, I would think that clamp style would be able to be sufficiently tightened to grip the leadscrew.

Set screw coupler


Clamp style coupler