X axis on table jams (sticks) and won't move when cutting

Are table is sticking when running code or even during breaking code. We’ve oiled as instructions. Not sure why it’t jamming. We’ve checked rollers, nothing looks like it’s hanging up on anything.


Theres a few things to do/check to get rid of this issue:

  1. Make sure that the white compression collar can be pulled back on the lead screw. Doing this will compress the spring, but the spring should spring back after releasing the collar.
  2. If 1 is not the issue, Loosen the two screws that secure the lead nut mounting tab to the torch carriage. Then retighten both of them.
  3. Break loose the four screws that secure the lead nut to the mounting tab.
  4. Jog the X axis back and forth. If the X axis still hangs up, its a sign that your lead nut is faulty and we need to send a new one to you. If it jogs fine, move to the next step.
  5. Jog to max +X travel. Retighten the lead nut bolts (use care not to flex the lead screw in any direction)

mine has been doing the same thing since I got it. Gets worse the closer you get to the stepper motor.

Mine did a little.
Lube up the lead screw. All I had was this and it works well

1 Like

Thank you, I will see if I can find some of this. Do you know if it’s a silicone spray in case I can’t find this brand?
Also, I believe I’m stating the correct bar issue. It’s sticking along the bar that goes across the back where the controller box is.
I will try the steps that Langmuir suggested as well.

Nevermind. I see the can states silicone now. Sorry.

mind is stopping and sometimes it goes full distance in y and x axis close to stepper motor and there is times i can touch the arm and stop the stepper then there is times the torque is so great I cant stop the stepper and there times i touch the lead screw and it stops I lubed the lead screw, took stepper off mtg bracket checked stepper shaft clearance to lead screw,move white collar with spring , loosed 4 bolts on lead nut, it happen ramdonly been running mach 3 on my cnc engraver and no problems any ideas
Thanks Terry

Do you happen to know if the lead nut spins freely on the lead screw? can you remove the four bolts and try that?

I switched the lead nut from the y-axis to the x-axis and it does the same thing. I also could stop the motor on occasion with my hand other times I couldn’t. X axis traveled freely without lead nut attached. I believe stepper motor or controller are faulty. Now what?

Hi @Mert570, I will discuss this with @langmuir-mike tomorrow and get back to. Just to clarify, is it the X axis or Y axis that hangs up? The X axis is the axis the torch carriage moves along.

The “y” axis, sorry I get the two mixed up. The one that does not hold the torch. The larger of the two stepper motors. Thx.

I should have updated my binding issue. The leadnut fixed it. works perfect.

1 Like

I wish that would have worked for me.

Hello Daniel- the lead nuts spins freely what i will do is a video and upload it to you when i get back in the shop on monday or tuesday

That’ll work, thanks.

I ended up fixing mine, I loosened the mounting hardware to the lead nut and ran it all the way over close to the motor and then tightened it. Seems to be working fine now. Must have been binding the closer it got to the motor. Only time will tell. Thx guys.