X axis feed screw sticks

hello, glad to be part of the forum, just finished assembling my crossfire pro and I am having trouble with the lead screw on the x axis, It seems to be binding on the lead nut. It works better if I leave the lead nut a little loose, but as soon as I tighten it up it will not move, any ideas?

Loosen the bolts that hold the lead nut bracket and try to square that with the rail. Also, oil the lead screw.

received quick response from langmuir systems, it was suggested to me to loosen the screws that hold the bracket for the lead nut and then tighten the screws for the lead nut and then tighten the screws for the bracket, so I tried that and it did not help, after hours of frustration I ended up swopping the motor from the y axis and voila now it works perfectly! He also suggested to lubricate the lead screw. What lubricant should I use? thanks in advance.

I use a super fine sewing machine oil…works well…no buildup…

Here is a link to a post that suggests that mineral oil is the best choice. I been using motor oil (synthetic) as suggested by the LS assembly instructions, but I may switch to mineral oil. I have coated the rails with it and it does well keeping the water spots from forming.

@firensteel I was assembling my table yesterday and realized I got the bearing ends mixed up. the three are not the same and caused the X-axis lead screw to be not parallel to the axis.

1 Like

Yep happened to a bunch of us :grin:

I thought they highlighted that in a manual update though.

That was the only real issue I had putting mine together. (I did have a “nuisance” issue where the nut size for something was different than what the manual said so I had the wrong wrench and had to walk alllll the way across the garage to get the right one :wink:)

1 Like

They probably did update the manual but that doesn’t mean I would read it. Not the first time my impatience has bitten me on the butt!
"alllll the way across the garage to get the right one " Hell, I do that all the time. Isn’t that normal? :grinning: