[Work Around Found] Local Tool Library Inaccesible - "WebGL Disabled" Message

" Issue:

When attempting to view generated outcomes in Generative design, the following error occurs: “We can’t show this item because WebGL is disabled on this device.”

User-added image


  • Out of date graphics driver
  • Unsupported GPU’s


  1. Update your graphics driver to the latest version. Drivers can be downloaded from the appropriate graphics card provider’s websites.

For Nvidia drivers download the latest driver for your graphics card here.

  1. After installing a driver, it is recommended to restart your machine before launching Generative design.


  • If using Docking Stations, then check after undocking the computer. If the docking station is the problem, it may be related to DisplayLink drivers defaulting to the lower end graphics card. See this forum thread for more information.
  • If updating Graphic card drivers doesn’t works then it is worth trying to completely un_install the older drivers and then installing the newer drivers by following the procedure.
  1. Go to Device Manager and click on Display adapters.
  2. Right-click on the dedicated Graphic card and select the context menu Uninstall device
  3. In the program Manager : remove anything beginning with NVIDIA.
  4. Restart the computer.
  5. Go to Device manager and scan for new hardware.
  6. For newly detected Graphic card install the latest available driver."

I have Windows 11 and have not seen that message. It might be what Tin is suggesting.

1 Like

Thanks for the effort.

I’ve confirmed my graphics driver is up to date. I think my 10 yr old laptop has just finally become obsolete, even with Win 10 (installed <1 yr ago).

Since nobody else is having the same problem, I am going to mark this resolved.

which version of windows 10 do you have ?

Find operating system info in Windows 10

To find out which version of Windows your device is running, press the Windows logo key key + R, type winver in the Open box, and then select OK.

Here’s how to learn more:

  1. Select the Start button > Settings > System > About .

Open About settings
2. Under Device specifications > System type, see if you’re running a 32-bit or 64-bit version of Windows.
3. Under Windows specifications, check which edition and version of Windows your device is running.

I am curious if it is a end of life for Fusion 360 version or not

Just for info, we’re running Windows 10.0.19045.2965 and have not had any issues with Fusion 360. I do know that Fusion auto updated 2 days ago. Current version 2.0.16265 x86_64. (We have a subscription, if that matters.)

I am not sure that I would claim that since @Simsworx, @TinWhisperer or myself do not have the problem that “nobody” else is likely to have it. But I do appreciate that you weigh our experiences so highly. :rofl:



I just figured if others had the problem, they’d also be on here whining like a 12 year old that can’t go to the mall on Friday night, like I am. :cry:


same probleme, all was working find since 1y, last update of fusion 360 end it’s broken. i have no graphic card on my cnc computer i use Cpu for graphics

Erwan from france

windows is uptoDate

1 Like

(I seem to be having trouble sending a direct message to you. I have tried 3 times. I guess I will need to do it publicly. I was able to DM another user in between the attempts to you.)

@Wsidr1: If you need me to generate a toolpath/g-code(s) for you, I would be happy to do it.

1 Like

I think it is too soon for any software on the market to stop Win 10 support.

Microsoft - Windows 10 will reach end of support on October 14, 2025.

I really doubt that Autodesk would do something to cut off an OS generation. Most software still supports Win 7, and a lot of corporate users of Autodesk are probably still running NT.

Some older versions of Windows 10 reach their end of life support in March this year.

Note: Fusion 360 will continue to work on the operating system after the March update, but will no longer continue to update. Eventually it will stop functioning correctly, as it no longer meets the minimum system requirements to run Fusion 360


Hello, today I am facing exactly this problem of selecting the tool. Some weeks ago I was using it normally. Now, the tool can´t be selected as a error message freezing the screen appears and blocks the selection.

“WebGL is not activated on the device”, that is the message that appears before clicking the tool and the error message freezing the screen.

Do anyone knows how to solve this???

I am using Windows 10
Version: 20H2
OS Build 19042.630
Windows Feature Experience Pack 120.2212.31.0

I don’t know if this helps, but this is a wikiHow page on 3 ways to enable WebGL. Navigate at your own risk. It has lots of ads, and distracting information.

1 Like

I’ll try that later today.

I use Micrsoft Edge for a browser. I already confirmed my Hardware accel setting, but I need to look more into the example in the WiKi article. May be some similar option in Edge. Or, I’ll just try using Chrome.

You are not the only ones having this issue.

Here is some information from the Autodesk Forum

1 Like

Following that post on Autodesk Community, a functioning workaround is:

Go to preferences → Preview Features → Uncheck the option “Tool 3D Preview”

And that removes de selection screen error of the tool.
At least you can finish your pending jobs if you do not need that 3D view to accomplish it.

Thank you very much for all replies.


Or need to edit the current tool. Apparently, that is still an issue with this work-around.

I think the good news is that AutoDesk is aware of the issue.

Good News: Yeah, that fixed it for me. I read it in the thread linked by @TinWhisperer Uncheck the “Tool Library - 3D Preview” in Preferences.

Bad News: Now F360 WILL run again on my crappy old laptop, so I have to come up with another justification to buy a new one!


great! it work again