What a nightmare

Bought the crossfire but having big issues either I’m a total dummy or just bad luck. My 18 hour into this nonstop I work a lot so I’m hoping to get it close to plug and play before I go back to work

Built …seems pretty square
Wired plasma cutter seems good I can turn it off and on manually ( don’t know if that’s right … I can’t download anything from fireshare to test)
When I do a dry run it worked only
One time perfect …but now the motors keep spinng against the axis “stop”
The couplers so cheap there stripping

Any help would be greatly appreciated

It’s really difficult to understand what your issue is. Is the stepper motor driving on it’s own or is this happening during the running of a cut file?

If it’s during the running of a file, it’s probably because the file is bigger than the table limits or you don’t have your torch zeroed in the right spot and it’s running outside the table limits.


Thanks for the reply !

It only happens when I’m doing the “ dry run” test when the y axis doesn’t not automatically stop before it runs into the metal tubing


It does not automatically stop before it runs into the tubing. Fire control has no way of knowing where the tubing is unless you have limit switches that are properly installed and calibrated.

You need to verify your design fits inside the cut envelope before attempting to cut or perform a dry run of a file.

You do this by jogging the machine around the envelope of machine to make sure the geometry shown in the visualizer fits inside. If any part is outside the envelope and you run the program you will crash the machine. When you get close to the extents you can change it from continuous to step mode (1” 1/4” 1/8” 1/16” increments)


When you load your drawing, jog the torch to the bottom left corner of the table. Then press the “zero all axis” button in Firecontrol. Jog the torch around and watch the crosshairs on the screen to make sure your design fits within the table limits before running the program.

Note: it won’t always be the lower left corner of the table, but wherever you zero the torch will be the lower left corner of where your design is placed on the table. This assumes that the origin of your design is at the lower left corner.


Man thanks for the help everyone…looks like my speed was way to high out of the box …so the couplers where spinning … however I believe that problem is solved for now….I’m going to take another day and see if I can cut out a simple sign … literally anything if I can download it

1 Like

Thank you I will def take your advice and try that today … I think I’m ironing things all the issues out now …I f I can get one cut today I’ll be happy