Torch will not turn off when hooked to controller

I ran all you tests you suggested even hooked up a brand new plasma cutter that is the same out of the box and performs the same. It seems like the controller is stuck in the on position. with no computer hooked up and turned on as soon as I plug into port torch is turned on. This is the same with both plasma cutters and yes they are pilot ark and read website and they were not listed as bad units. It worked more then perfect yesterday with first fire up and simple test part. Today started test part with lower amps fired up and turned off then when testing next part with higher amps fired up and would not turn off and that’s how its been sense tested all cables plugs and even new cutter. Seems to be hardware issue.

Sounds like the torch firing relay is stuck. Relays go bad. Contact Langmuir support.

Which plasma cutter are you using? Pilot arc doesn’t mean its not high frequency.

1 Like

how do you test that? is there a wiring diagram for the controller somewhere

also said in description it was not high frequency when I bought the plasma cutter

Welcome to the forum…let see if we can help…

We have had a few people say their plasma units are not High Frequency…only to find out they have high frequency.
Then there is the fact that some plasma machines have inherit problems or little issues thaty other machines do not…

it helps us rule out issues when we know what plasma machine we are dealing with.

This is the relay.

You can test it by checking for continuity across the center pin and outside part of the port on the electronics enclosure. If there is continuity, the relay is stuck.

If your particular plasma cutter causes a voltage spike to go through that circuit, when it initiates the pilot arc, it will fry the relay.

If you paid less than $600 for it, the chances are very high that is a high frequency machine. Why not just tell us what it is?

I’m not home I’ll send the link when I get home it was just a little over 400

looking forward to it…thanks

I’m pretty sure that’s HF start. I have the Lotos LTP5500D-CNC and that, I think, was Loto’s entry into blowback start. The Lotos info specifically states Blowback start with the LTP5500P.

“CNC ENABLED Pre-installed CNC Interface with THC (Torch Height Controller) signal output. Non-HF Blowback Start, there is no HF interference on your CNC computer.”

There is no mention of this with the LTP5000D

1 Like

Ok it did ask seller if it was hf start before I bought and he said no but he could be full of :poop: just trying to get the sell. Also I have a hf start plasma cutter and there is a very distinct nois it makes when starting that this one does not have. Just tested the relay and it is bad how do I go about getting a replacement

Wait I may have read wrong if I use the beep tester and it beeps when i touch the center pin and the outer part it’s bad? Because that’s what it does

Place one probe inside the barrel connector and the other on the outside. it shouldn’t beep.

Then in firecontrol, click on manual fire and do the same test, it should beep.

if it passes both those tests, the relay should be good.

Ok with controller powered off no beep as soon as I turn power on it beeps

remove the relay and try it your way again. if it doesn’t beep that time with power on , then relay is bad.

Also after some investigation does this pic look like a hf start system?

Also no beep power on or off with relay unplugged. Only beeps when relay plugged in with power on

I’d say its bad with it being stuck in the ON/CLOSED position.

1 Like

Yes agreed