Torch not moving when THC lights say "down"

Was cutting some steel that was warping bad today, and kept having the torch not cut the entire way through (you know, the rooster tail of sparks). After investigation, I found that the torch was too far away from the material when the rooster tail occurred. This lead me to start testing my THC to see if it was behaving as expected as I have had trouble in the past with it.

I generated a 14" straight cut, and blocked up one end of my material to about 3" off the slats. A ramp test.

Starting from the high end of the ramp, I could clearly see the torch was not traveling down to follow the ramp even though the THC lights said “active” and “down” as well as my nominal voltage (roughly 142) and live voltage (varied as the torch traveled along its path and kept getting father from the material). Clearly the software wanted the torch to travel down to equalize the nominal and live voltages, but it just wasn’t keeping up.

My IHS and manually moving the z axis seem fine, so I doubt its a stepper motor issue. Does anyone have any ideas as to what I can do to try and narrow down what is going on here?

Are you entering a value for voltage or letting the system detect it on pierce?

I have tried both, with the same results.

Also, as a note: I have cleaned my torch mount tons of times, as well as added that rubber funnel thing in an attempt to keep debris/water out. Going to try cleaning it again I guess.

I don’t think cleanliness is going to be your issue. Is your laptop plugged in to a grounded outlet while cutting?

Have you tried slowing the program down? Looking at your failed cuts I’m confused at the pierce point on each end.

I am using a desktop with a USB isolater, which I have been using just fine for the last 6 months. Despite how the photos look there is only one pierce point per cut. Some of the cuts at the top of the photos I had going the opposite direction. These seemed to work fine - but I believe that is because the torch was contacting the work piece which makes it raise itself up due to the nozzle contacting.

Hmmm. Very interesting. I’m not at my shop, and I haven’t poked at the THC options in a while, is there a setting in firecontrol for THC sample size or response rate or something?

What’s your program speed for this test, I want to try it and see if my machine will handle the 3 inch ramp up.

I’ve seen videos of the machine handling similar, so I’m at a loss as well.

Assuming your voltage is good, its not able to keep up because of the Z Speed Factor. Likely too low for this slope.

The Z-Speed Factor setting is used to tune the Z-axis travel speed when the THC module is in control. The Z-Speed Factor is used to set the real-time Z-axis travel speed as a percentage of the real-time XY travel speed. This makes it so that the Z-axis motor can move faster when the XY speed is faster, but also slow down when the XY speed gets slower such as around tight corners or small holes. This feature allows the torch to react to sudden changes in plate height when moving quickly, but also prevents the torch from plunging downward when the torch speed slows down. The Z-Speed Factor sets the Z-axis speed based on a percentage of the current XY speed. For example, if the Z-Speed Factor is set to 10% and the live XY speed at some point during a cut is 100 IPM, then the Z-axis speed at that point in time would be 10% of 100 IPM or 10 IPM. If your plate is especially warped, you may need to increase the Z-Speed Factor so that the Z-axis motor can move quickly enough to keep up with large changes in plate height. For most cutting needs, the default setting of 5% will be sufficient. For example, a 5% Z-Speed Factor can correct up to 4" out of flat over 48".

The max Z-Axis travel speed under THC control is 60IPM; if the calculated speed exceeds 60IPM then 60IPM will be used.

The Z-Speed Factor can be set anywhere between 1 to 99%. The default setting is 5%.


Yeah, that’s what I was thinking of. Lol

The Z speed factor percentage is just the grade of hill that the torch needs to climb up or down. 3” of hill over 14” is a 21% grade. So the Z speed factor would need to be set to a minimum of 21% for this cut.

A rule of thumb though is that you want the percentage to be as low as possible to avoid hunting and oscillation.


Thanks for the reply everyone - I adjusted it and recut the parts I was making. They warped as expected, but with more z speed factor it seemed to keep up with the material better. I do notice some oscillation a few inches after the initial pierce but I’d rather have this then failed cuts.

Excellent explanation… Even I can understand it once you put it that way!! :crazy_face:

1 Like