Torch Not Firing with Everlast PowerPlasma 62i CNC - SOLVED

I finished assembling my CrossFire XL, did the alignment and break-in program. I wired up my THC using the raw voltage on the DINSE connectors inside my Everlast PowerPlasma 62i CNC package and soldered the Torch Firing wires onto Pins 1 and 2 of the CNC port. Next, I fired up the plasma cutter with good air supply and work clamp attached and tried to test the THC in FireControl v20.6.

I got past the first part of the Resting voltage test and got 1.0 - 1.2v. The problem started during the next portion of the test when it tried to dry-fire the torch. The air kicks on and is coming out of the torch, but no arc comes on.

Then I closed out of the test and tried to manually fire the torch in FireControl, and the same thing happened - air comes out, but no arc starts up.

This is a brand new plasma cutter and I did not get the hand torch, so I cannot verify that the plasma cutter works that way.

I turned the plasma cutter off and hit the manual torch fire button in FireControl and heard the relay click.

Any ideas?
@toolboy I think you have the same plasma cutter, so I hope you could jump in.

Where is your mount attached to your torch?

It the plunger getting stuck or is stuck?

Can you verify the consumable pack and make sure everything is moving free.

Is the everlast coding out?

What is your entering a pressure?

As said, if you are clamped to the torch head you may be jamming things inside. This will not let it fire. Also check your consumables and make sure they are all there.


@TinWhisperer @mechanic416 That was it! The bottom torch mount was clamped partway down on the torch head. I lowered the torch down and it fired! I don’t know how I missed something so simple. 123.3V average.

Thank you so much!