Torch Not Firing - Troubleshooting Guide (MACH3 LEGACY)

I am having the same problem with the torch skipping letters and cuts I have the razorweld cut 45 and wired it inside. I also have the two ports on the front are they for the wires from the control box and how do we set that up if it is

OK so…… I’m having a similar problem the reverse problem actually, I can get my torch to fire up just fine only thing is it likes to keep cutting when tracking to the next position. For EX: cutting a silhouette some or most of the holes within it will cut just fine except on usually one of them will keep tracking with the torch on still and it cuts where I don’t want the cut, Essentially cutting off or through things where it shouldn’t. I’ve double checked my programing and everything seems ok. I think it might be the torch on/off switch on the Langmuir black box that probably needs to be replaced. Anyone else have this issue?

have you got a 2T and 4T switch on your plasma cutter? maybe it’s in 4T mode?


Yes I also am having the issue with firing while tracking, using a Cutmaster 42. Also have initial start up issue it blows air but doesn’t fire until about an inch into the program

That’s a known issue with the Cutmaster 42. You’ll need to account for it with pierce delay.

Resolved the pierce delay issue thank you.

Any idea on the firing while jogging to other cut?

I tested the wiring and the motion board

I was sent a new board by langmuir.
I put it in yesterday morning.
I cut one sign with it no problem at all. I thought okay I’m out of the woods now. Put another plate on it did the same thing it was doing before, blowing lots of air just tracing the part

I can make the torch fire manually.
When I unplug the the torch on/off cable and plug it back in it automatically fires. The f5 button in mach 3 hasn’t been pressed when it does this either.
I’ve been through every step on this page. Everything checks out fine.
I’ve had the crossfire since late November and cut probably 5 parts with it.
Could the relay be getting hot and quitting working?
Ive also tried rebooting everything when it starts doing this.

did they send you a new relay too? there was a post on here about a few being faulty.

I ask about a relay to begin with. But they were sure it was the motion board

DJ how did you make out? I. Having the same issue. It cuts intermittently. It was cutting great I didn’t use it for a week then this started. I’ve read it’s most likely a relay. Wondering if you ever got it solved.

Yes sir I did. They sent me a relay , motion control board and a wiring harness. They’re very slow to answer.

yeah Ive gone through the checklist with no help. Very frustrating. My torch fires then just kicks off. traces and the fires again. like its popping a breaker, overheat or something. Wish I was better with electronics.

You don’t have to be really good with electronics. There’s a list in this thread somewhere that tells you everything to check. I went to harbor freight and got a voltmeter watched a few YouTube videos. Then sent langmuir a detailed email with pictures. That was w hff at finally got me running and no problem since.

Yeah Ive worked through their checklist and it seems fine, but even if I cut manually with the manual button it cuts out after a few seconds. Going to go check again

Good luck man!

ty… Im thinking its the relay even though its showing continuity. From reading on here with peoples similar problems.

If it is probably messed up your harness and motion control board too

awesome lol

I am having the same type of issue. Razorweld 45 worked great first few cuts I made then it started to miss fire the torch. What it is doing is firing every other time. If I am cutting out letters it will cut the first one fine, then move to the second one, Mach3 shows torch should be firing, relay is pulled in, connections are all good but will not fire until finished with second letter then moves on to the third and it fires torch fine. I have replaced relay and harness they sent. Air pressure is good, air is dry, table is level, did all the tests they have outlined here, checked voltage, tried different computer, moved table as far from Razorweld as possible, made sure computer and table are on separate outlets, put ferrite beads on usb cable, changed usb cable.

One thing I noticed is when torch is firing the 2T light is flashing on Razorweld and when it is not firing and should be that light is just on solid.

Not really sure where to go from here. Any ideas greatly appreciated.