Torch not firing sudddenly

Hey guys,
What is the likeliness of the little slit crimp connectors going bad or not working correctly after only a couple cuts? I haven’t touched my machine in a couple weeks and only cut out a couple tabs and tried the architectural plate and the torch fired no problem. Now I was trying to cut a fathers day gift and I ran into mach3 not having enough lines so I will have to purchase that so I started trying to cut out and extinguisher mount and the whole time I was setting it up I had the torch fire cord unplugged and when I was finally ready to cut, the torch wouldn’t fire. I really don’t have time nor will I have time for a few days to open the plasma up again to check it so I figured id ask here. this is quite frustrating but I am not sure if its something I am doing wrong on my end software wise.
any help would be greatly appreciated.
thanks guys!

Can you post a pic of your Mach 3 desktop? Do you see “Crossfire” as the profile in the bottom right status box?

Does it fire if you hit F5?

Did you turn the Crossfire control box on before you started Mach 3?