Torch not firing on cut path but will will fire manually (SOLVED)

They have a telephone number on their website now. 833 526 4797 now to get someone to answer the question.

1 Like

I will give that a try? Thanks for your help

1 Like

reading this is both comical and frustrating at the same time. They did not send a particular cable with my machine. The cable with a barrel plug that is intended for wiring into the plasma to fire it. I went as far to track down a picture of it and send it to the rep in the email… They still sent me the wrong parts

Langmuir is a charge back scammers dream purchase. The people cant get shit right and the machine is so cheaply built without much fore thought that I can help buy feel a bit took. I havent reached out to them again, but i may. They better get their shit together or it looks like they will be giving out a lot of machine for free when people become fed up and call their cc companies

Sounds like you need to call your cc company in the morning.


So how is your machine poorly built. Just like everything else improvement could be made. These are budget machines for one.

I have had my machine since the spring of 2021. There are some that run their machine more than me. I run mine none stop for hours at a time. The only issue I have ever had has been the operator.


That’s cute. I built a router CNC from scratch a year back. Spent exactly the same money. Linear Rails. Ball screws 2x2 1/8 wall steel tubing. Can do 10,000mm/min rapids carrying a 3horsepower 3 phase spindle. Unit has been flawless. And its running on a board designed by a single guy in the community who did it for fun, not profit.

So what’s langmuirs excuse? Excuse for me getting dinged up tubing but not providing replacements when they were made aware? Not sending the correct wiring TWICE? I wasn’t rude. I wasn’t demanding. This attitude come after the lack of service was provided.

They don’t have an excuse… they just don’t do or say anything and expect customers who don’t know any better to defend they skateboard bearing using pile of junk. I mean they didn’t even have the sense too mount the controls in a location where it wouldn’t get rained on every time a cut took place in that corner of the machine.

Add insult to injury, the software is buggy. I can use a generic Gcode sender, but no using the THC then. This is a diy kit sold as finished/polished cutting solution. False advertising. I expected a cheap system. I expected the 60 to 8 bearing riding, budget oriented method of getting it done. But with the cost cutting, I expected a polished working system. Not a forum full of posts by the company explaining why their shit don’t work and that they are working on getting the bugs out. They are working on getting the next product out, not fixing the short comings of their other products

You get better service buying shit ooff aliexpress. Seriously. :expressionless:

I understand you may not be satisfied with your purchase. The issues you explained could have been seen prior to the purchase though.
I have never seen this company not make a issue correct.


Your problem should be easy to solve, either the control box is not putting out the signal to turn on the torch or the wiring on the plasma has a problem, the output from the control box is just a set of relay contacts, if you connect an ohmmeter to the torch pins of the control box you should see a short or ZERO ohms-when the program is calling for it to be on–if you do not the problem resides in the control box, if you do see the control box is providing a switched on (zero ohms) signal when it should than the problem is definitely something from the control box to the plasma cutter since you can trigger the torch manually that’s all it can be

1 Like

Langmuir has sent me a complete electronics box. I’m installing tomorrow. Will see what that does. Thanks for the input.

1 Like

The new box worked just fine.