Torch not firing hand held or in unit

It was cutting and it just stopped. This has happened before and I just changed the tip and electrode went on about my way. I replaced the parts and still the same issue. The air kicks on and off but no plasma. If I scrape it on the metal i will get some arching. Any info or advice would be appreciated. Its the Viper cut 30i. Never had any problems until now.
That link should be a video of what’s going on.

Have you checked your connection where you attached your wires to the plasma? The wires that go to the control box. sometimes they need wiggled/turned a bit if there losing connection. And your ground.

Well i disconnected the taps to that cable all together so it just the plasma cutter. And the ground clamp is directly on the metal piece. Still having the same issue.

Do you have around 75 psi of air at the cutter ? Silly Q but there are so many small but simple things we all can over look . Ok i watched your vid. Looks like your not getting your initial arc wich you should get regardless of a ground. Only way my 30i wont is when air is to low. Looks like its time for a more knowedgable person to jump in.

1 Like

Remove your cap and have a look at the plastic around where the cap screws on on the torch side. There should be 2 little pins that are spring loaded and contact the inside of the cap when it’s on. One of those pins might not be making contact. Those pins and the cap comple the circuit for the hand torch trigger. The clamp on the crossfire can deform the plastic and make them stick and that will prevent your trigger from working.

1 Like

I did not replace that small plastic piece (swirl ring) in the tip. I did order a new one so I guess I will see. I spray those contacts off with electrical cleaner. My air pressure has been the same but Ill play with that some more.

I had the exact same issue with my 30. Ended up sending it to jasic and ended up being something with the torch. But I was already fed up with constant issues from it I sold it and switched cutters. Hopefully you get it fixed

I ordered a new swirl ring. Hopefully that resolves the issue because I cant really afford buying a new cutter. My wife was told she is losing her job Dec 10th so spending is on hold right now.

If your still having trouble with it contact me and I will help you out.

Thanks. I should get the replacement ring on Friday so after i get home from work I’ll try it out.

I have the same problem. I called Razorweld and was told the torch shorted out and needed to replace it at $135. The torch only has a 90 day warranty. I think it is ridiculous they do not stand by their products. Call Sean at (253) 859-6277.

I am a little disappointed. It sat in the box for almost a year before I put everything together. I’ve only really been using it since the end of Sept so warranty is long gone. I did pull the torch apart and saw some corrosion. Ill try the swirl ring when I get it per some tips I got from someone. If that doesn’t work I’ll take the torch apart again and try cleaning that up. I found the torches for much less. What I’ve learned is they a standard S45 Tramefit torch. In the end I’ll report back what I do because this seems to show up a lot in the forum and there has never been any followup other than buying a new one. For me right now isn’t an option.

A real original Trafimet S45 torch will cost about $300 or more. The Viper 30 uses a S45 clone.

1 Like

Ok so the swirl ring wasn’t the fix so i proceeded take the torch apart because i was going to clean up that little corrosion. When i took it apart i believe o found the culprit. When I plug one end and blow in the other I can feel the pressure being lost so the was a leak somewhere. Looking at it you cam obviously see there was a blowout.

Ok so here was my fix… I wound up buying a replacement torch head on Ebay for 93 dollars. when I got the new torch head it was the same type but obviously not the correct handle. So i milled out some of the plastic parts inside to form around it to fit. It fired up and worked manually great. When I placed it back into CNC there were all kinds of malfunctions. I spoke with Mechanic on the phone and he said many things about the consumables and why not to get the Chinese knockoffs. One thing he said was the nozzle should have 6 holes inside and a lot of the Chinese ones dont. I looked in the nozzle and sure enough there were only 4 holes. I dug out the old nozzle with 6 holes and its been working perfect. I have made 8 signs with no problems and the quality is coming out the same as before. I still bought the replacement Mechanic had because it is better and it will be good to have. I plan on using this Frankenstein one to see how long it lasts. Thanks for everyone’s input.

JFab Where exactly did you find the part on Ebay? Was there a pat number or a store I can look up? I have the same issue but all I can find is the entire torch assembly.

The person I bought it from is no longer listed on Ebay but the 1st link I post is one like what I bought. I did have to make some modifications to the housing. The second link is another torch assembly I bought. its was much more expensive.

replacement torch head

Replacement complete cable and torch

I bought a completely different plasma cutter. If you want the cable I repaired Id be more than happy to send it you. It worked good I just wasn’t sure how long it would last so I bought the new cable. FYI I only used the new cable once to see how well it worked.