Torch not firing, but does manually

This is so weird, I haven’t posted because I can’t offer anything. The problem is either in mach or the G Code is my guess since F5 works, but who the heck knows?

Hello, I am running into this same problem. Here are the details:

  • Windows 10 laptop with patch installed
  • Everlast 50s
  • F5 test works
  • Can correctly see M3 and M5 codes in Gcode but it isn’t firing.
  • Restarted program, relaunched, etc.
  • Origin set and zeroed out (0.0000)
  • 2T enabled

@Markc Did you ever figure it out?

Does it fire for you if you hit F5 in Mach3?

He said it works when he uses F5.

@jamesdhatch Yes, as mentioned it works perfectly when hitting F5.

I also tried manually starting at the first line of code with an M3 to see if that would work and it did not.

That’s good because the torch physical wiring is correct then.

The M03 should trigger it too though. In Mach if you’re on the main screen and press Alt+7 you’re in the diagnostics screen. Click on the Spindle Toggle button (halfway down the screen) and see if the torch fires. Then in the command window try it by typing the M3.

If those all work, then there’s something up with your tap file. You’ll need to post it up here so one of us can look at it and see what’s up with the code that you’ve generated out of your post processor step.

Thanks for the tips. I finally gave up and dusted off my old Windows 7 laptop to try that. Thankfully the same files worked perfectly on the other laptop. Definitely off but I’m just happy it works!

I had installed the Windows 10 patches well.

That points to the Mach3 install being different. Worth checking to see what happens if you reinstalled in the Win10 laptop and tried again using the same steps (plus the Win10 patch) you followed with the Win7 laptop.