Titanium 45 plasma cutter will not stop firing when turned on

I wired my plasma cutter according to Mike Festiva on youtube who owns the same cutter and table. When I turn my plasma cutter on I get and F05 error number. This means the torch trigger is stuck (which it is obviously not). When I try to run the program on fircontrol it tells me that my “TORCH STARTED MOVING BEFORE CUTTING VOLTAGE WAS SENSED.” I ran through the steps to fix it, but it still does the same thing. Please Help!

Welcome to the forum. There’s some super smart dudes trolling around here… so much help.

A bit more info would be helpful to start with… handheld or machine torch on plasma? Pic of your wiring to switch wires inside plasma unit. Have you used the titanium 45 for manual cutting prior to this cnc install?

1st separate the 2 systems. Unplug torch switch wire from your control box. Turn on plasma unit. Does plasma turn on without error? If you have hand torch, Remove the torch lead from your plasma unit and turn on. If neither of these tests resolved the startup error, then it’s your switch wiring inside the unit, or a bad plasma unit.

Let’s figure that out before jumping into possible issues on the Langmuir side.

Titanium 45 manual

It’s always nice to post these manuals as reference, especially for the obscure plasma torches.

1 Like

Thanks for the speedy reply! I think I may have bit off more than I can chew, but Razorweld was on back order and they could not tell me when I would be getting the cutter I bought so I returned it and bought this Titanium not knowing I would have to wire to the raw voltage instead of just plug in play with the CNC table.

I separated the 2 and it worked just fine, it even cut when I activated the trigger manually. It won’t allow me to post photos on this forum because they are too large and I don’t know how to shrink them. Do you have an email I could send them to?

figured it out. Only allows me to post one at a time here is the torch firing wiring.

here is the negative attached to the PCB

positive attached to the positive socket for the clamp

Here is a whole picture of all wiring

Well, now ya only have one side to figure out.

Did you double check the solenoid for plasma on / off?is it secure on the control board… the square one.

Leave plasma disconnected and off. Get fire control loaded up. Now listen closely when you flip the switch on the control board for table.

Turn on table control board, did you hear the solenoid click when power came on?? (It shouldn’t) if it did, get support on a replacement.

If no click when power on, Run a little jog test to double check you’re connected good. Now slide the manual fire switch and press the fire button. Listen for the light click from the solenoid. Did it happen? If it clicked, then signal is getting to there… problem is wire between the 2.

Its possible to have a bad solenoid… or solder bridge on a connection up the signal line. If it’s still firing when you turn it on… shut it all off, unplug… then pull the solenoid off board… turn it all back on with the solenoid out of board… did torch fire when turned on?

If this last test resulted in the plasma firing without the solenoid in place, go through all your wiring again. Somewhere the switch lead has been bridged.

Okay so it clicks when I manually fire the torch on firecontrol. What two parts is the wiring bad on?

Do you have a multimeter? If so, test continuity between the rings on the 1/8" plug that goes into the control box. They should be open.

The last test resulted in the f05 error. Torch was firing when I turned the cutter on without the solenoid

Pull the connectors off your wire taps in the plasma cutter

And recheck for error on startup

No error when torch firing wires disconnected

Where is that specifically?

Well, your problem is between the solenoid and your wire taps into the plasma unit. I can’t see all the wires in your hookup to the plasma trigger leads, but somewhere those wires are closing the circuit at all times and should not be be. Check inside the control box where lead plugs in…

I’d pull solenoid and test continuity between posts. In to out should be open. Test the trigger line for continuity all the way to your taps.

On the euro connector pins 1 and 2 are the trigger, pins 5 and 6 are the pilot arc and pins 8 and 9 are the safety or cup pins.