THC live voltage 0.0V

Finished setting up my Crossfire XL with limit switches and THC controller. I did the THC test and got the message stating that the live voltage was 0.0V. I tried the listed suggestions except for removing the electronics box and retested with the same result.

I did end up making my first cuts with the machine and it worked very well overall, but I would like to ensure it is doing what it is supposed to be doing.

Any comments/suggestions would be appreciated.

You don’t have it hooked up right or have a faulty VIM box if you’re getting 0.

Tell us how you have everything connected. Pictures help also.


I will get some pics today. I am using a Hynade CUT60 CNC capable plasma with machine torch. I followed the instructions and watched a video from Mike Festiva on YT. I have tested the continuity of the wires but not the voltage yet.

The output of the VIM box is the straight output (verses the divided), I was/am wondering about this aspect.

The CNC version of the hynade cut 60 has a raw voltage output port. That should be connected to the wires with the red and black banana connectors on the ends. The red wire to the positive on the plasma cutter and the “clamp” port on the VIM. The Black wire to the negative and the “torch” port on the VIM. Output from the VIM should be “PV out” to THC port on the control box.

1 Like

Ok so I took some picture, reviewed the wiring and did not find anything wrong.


That PV out cable looks odd. Why is it angled like that and not fully pushed in?

I saw that as well and removed it, then reinserted it but it looks the same. I took the cover off the VIM to see if the connection was loose/bad but it is fine. It appears that the cable is somewhat loose on/in the connector.

Have you measured the voltage coming out of the cutters output port to see that it’s working?

That connector shouldn’t be loose. The only reason it COULD be loose is mismatch of connector pins (VIM is 2.1mm diameter pin, and Plug is designed for 2.5mm pin). Since I don’t have a VIM, I can’t tell you what it should be…

A loose connector will be unreliable.

Not yet I haven’t, its on the list of things to do.

I agree about the loose connector but since its it a fixed plug the only option would be to replace that cable.

I am new at this I don’t know what I don’t know, but the machine seems to be functioning correctly, it moves down and touches the material and then retracts and fires cutting out the design. I began this thread because it failed the test but I am not sure what I am testing to be honest. In other words, what isn’t my machine doing that it should be?

If you’re getting 0 on the test your THC isn’t working. If you’re able to cut and use your machine, you may be post processing with the wrong processor or using cut ready files not made for a THC machine.

I think.

1 Like

Which I HIGHLY recommend if the connector is the wrong size.

It isn’t reading voltage, so the Torch height control won’t work and will throw an error every time you try to cut with it activated.

Many people mistake the function of the IHS (initial height sensing) system for the THC. They are completely different and separate systems. The IHS system will probe the Torch down, set the Z zero, raise to pierce height and then lower to cut height. This function occurs whether you have a THC or not.

The Torch height control only controls the torch height after cutting has started and it has taken a voltage reading. It uses that voltage reading to keep the torch at the same height above the metal, by adjusting the torch up or down to maintain that target voltage.


Thats the explanation I needed, thanks.

1 Like

I will look at it again, I don’t think the plug is the wrong size but I guess it could be.

So I spent some time checking the cable, it is NOT loose in the VIM it just appears that way. I have another brand new cable with the same 2.5mm connector and it has exactly the same fitment. Additionally both 2.5mm connectors sit/fit exactly the same in all 3 of the receptacles on the VIM.

I disassembled the VIM and checked to ensure that all of the receptacles are soldered correctly onto the board and that there is not any movement (which there isn’t). The board is in good order.

I continuity checked the cables and all connections (that I could) and everything seems to be as it should be. I checked to ensure that everything is connected and seated correctly.

So now I need to check voltage, any tips here?

There is a thc trouble shooting flow chart pinned on the forum. It has step by step instructions.

1 Like

I would start at the pins on the back of the plasma. Make sure you’re getting voltage from the pins when the plasma is firing. You should get somewhere between 80 and 130ish volts. Then connect the cable to the pins and make sure you’re getting the same voltage at the connector on the other end. If both of those are good, connect to the VIM and check the output at the PV out. Voltage at the PV out should be less than 3v, if I remember correctly.