Struggling with XR

So I’ll start off by showing I’m not a complete tech idiot.
I took a 1981 Bridgeport Series 1 CNC, replaced the screws with ball screws, gutted the electronics, rewired with new VFD, new Servos, new drives, acorn Cnc controller, works flawlessly. Can hold accurate .0008-.001 all day long now for over a year with weekly use.

This XR Pro… since new…
It’s within 1/64 of being square and I spent two hours leveling the thing. Following the instructions for assembly to a T.


  1. the plastic cover over the torch was not trimmed large enough and the torch (hypotherm machine torch) constantly stalls then jerks when it’s cutting. I trimmed the plastic bigger but it’s still wonky.

  2. anything over 200ipm it gets out of square and completely screws everything up, which was a huge problem until I figured out in settings you can slow the machines travel speed between the cuts…. But it’s really quite annoying.

I double checked, triple, then quadruple checked that the rails are 100% inline at every point on the table, and when homing the machine it is perfectly square with the rails so it’s starting off straight.

I then bought a $100 torque wrench that went down to 10 inch lbs so I could be 100% certain that the ball screws were in the exact same tension. I tried at 20 in-lb, 30, 40, 50, 60, 70, all the way to 180. Nothing helped it move uniform.

I loosened the jam nuts on ball nuts…. Nothing, tightened them…. Nothing, tried them at a happy medium, nothing. Removed the felt pads, re-oiled them. Nope.

I covered entire ball screw in assembly lube. Nothing. Greased the entire rail. Nothing.

One thing I think might be the cause, one of the gantry upright braces seems to be bent (or wasn’t made perfectly straight) from the factory. When the machine is homed, one of the rollers does not touch the rail. And nothing I can do will make it touch.

  1. I will begin a cut with THC on, it will cut the first hole at normal height. Move to the second hole, start the cut 1.5 inches from surface and not cut anything. The ground is directly connected to the workpiece. No idea what to do here. 90% of the time I push retry cut and regenerate code it either starts back in the wrong place or completely skips one of the holes.

  2. it constantly fails to start because it detected some voltage prior to moving or something. I don’t recall the exact error but I’ll try it tomorrow and update with exactly what it says 1 out of every 5 times I start to cut with it.

  3. the mechanism that is used to hold the torch at 90 degrees from the workpiece is poorly designed and moves constantly. I plan to drill holes and put two u-bolts on it.

I’m ready to sell it and buy a more expensive more reliable unit. I use it to cut custom brackets, ears for pins etc… 5-6 times a day every day of the week. And it’s gotten to the point where I just use the handheld plasma, freehand and grind rather then screwing with this for an hour to get it to cut something.

Welcome to the forum.

You should know that there is a hotline for XR users if you have problems. Unfortunately it’s 9-5 M-F PST. Check Langmuir’s product support page. See:
Xr Support | Langmuir Systems click on technical support for number.

But I will move this to the XR category and alert @langmuir-cameron who does XR support.

1 Like

If machine wont travel at 400ipm, then you need to go back and recheck all the bearing preloads on Y axis. If to lose the left/right y axis will not stay square to one another when traveling/stopping, going to rack out of square. If bearings to tight will bind and stall motors.

1 Like

As far as you machine cutting to high is there a chance that your having electrical interference? Maybe even something tripping the ihs switch to early?

Sounds more like electrical interference. Do you have your computer on a grounded plug. I am not sure it it’s a problem with the xr tables most people use a ground isolating plug on the pro tables. You can get a ground loop between the plasma and your computer through your breaker box.

Maybe someone with a XR can confirm if this is a issue or not.

I bought the extra long machine torch, and special ordered longer shielded cables for the THC so my plasma cutter is on the opposite end as the PC, about 5 feet away from the corner of the table.

It is wired to a grounded plug. But I’ll play with it and see if I can isolate them more.

The only way to isolate it is to use a ground isolating plug. The ground loop comes through your breaker box and back to the computer on the third ground plug. I am not sure if this is a problem on the XR but I would assume it is To test that on the pro most would run on the laptop battery. Using a PC you would have to eliminate the ground plug on your PC.

This ground is can wreak all kinds of havoc.

1 Like

Take that cover off for now and worry about that later.

My advice would be take these problems one at a time.
you start making changes to a lot of different things its hard to know what helped and what did not

1 Like

Yesterday I played with preloads for about an hour. Tried several spots. Still can’t go about 200.

I’m still convinced it is the warped gantry upright. The back guide roller touches on both sides, the bottom touches on both sides. The front only touches on one side. Today I plan to remove that roller and put a ground down washer behind it to try and move it over about .01 inch.

Will update how that works.

If you have time take a picture of the problem would like to see

Tom, I see you mentioned a “HOT LINE” for XR users. Where did you find that number and do they actually answer the phone when you call or do they just allow you to leave a message and get back to you at their convenience? Thanks, Tom.

Click on product support, click on Xr and you will see phone #. People that have called support posted on this forum that they are quick to call back or answer the phone when they have called.

1 Like

Click on the link I provided in the post.

@lowchops 936-235-3991
I use that number because it is direct, for some reason the number on Langmuir’s website always routes me through a 1-800 number and I’ve had someone in the California office pick up.

Have you had anymore luck with your machine?

I’m having a very similar issue with the x-axis. It does not seem to matter what I do or how well I align things the x-axis will not travel without stalling. Even when it jogs doing a part it will slip and lose its zero. Did you ever figure out what was going on? Any suggestions would be greatly appreciated.

you will have to share a lot more info on what’s going on or better yet a new post with your concerns.