Strange Issues, mach3 and torch, XP30

I know there is alot on here with torch misfire and mach issues. However none that I’v found with the Hypertherm xp30. Or atleast my problem. Running 220v, laptop plugged in, good air pressure, dry
air for now I think (no desiccant at the moment) brand new plasma. newer 200 amp service panel.
Plasma plugged directly into wall. CNC box and laptop plugged into ext cord. Laptop is on a metal cart.

I just can’t seem to catch a break. Haven’t had one successful full cut yet. Other day I did some sample circles after having issues with coupler being loose. Cut sample circles out and that did go well, but was literally a small area and not much run time.

So I’m ready to cut about 1/8 material a medium sized sign. First two cuts went good then torch stops
and my plasma went to blinking light. (consumable light). I turned off plasma restarted and now I have two blinking lights. So I call Hypertherm up and the guy was cool, looked it up and said when these two lights blink it means there is something trying to power the machine bf the machine can boot up. So I “unplug” the trigger wire out of the CNC and boom plasma is working. Go to run the program and it cuts and stops. I gave up that day with frustration. As I literally have a problem with something every time I set up to sample cut anything. Another very interesting issue I feel I’m having is this is the second time I’v noticed the artwork being cut upside down. So meaning dross would be on the front part of the sign, not the back. Is this a Glitch or a setting? You can see in the picture here, the letters EYF as it should say FYE.

Day2. new program. Had 3 shapes to cut out all identical. First shape cut perfect, go to second shape, no arc. Plasma now has a solid consumable light lit. I’m using brand new fine tip consumables installed correct. Call up Hypertherm, guy was not easy to deal with. Made it out like he didn’t want to help bc they don’t condone hooking the plasma up by tapping into the trigger wire. I atleast said hey what causes the consumable light to be on. He ruled out, lack of air and moisture. Said it was in the trigger. So my guess is, the torch is fine as its brand new and consumables are brand new. Could it be 1. Loose connection 2. Mach3 glitching 3. plasma too close to the laptop? they are close

I don’t believe I’m getting the controller error. I will hopefully double check on that tomorrow. and also try move laptop away from plasma. I just find it weird that I’m getting two different plasma errors on two different files. I bought the hyp xp30 because I didn’t want to risk any pesky little issues that using an inferior brand presents. So I don’t know if its a Mach issue (since some signs are cut backwards, if its a Controller error or Plasma)

again I’ve had some parts cut out, but cut speeds and accuracy were off. So those are issues in themselves that I’v ironed out. Im now having torch issues.

Sorry for the long rant and if any of this was gone over. Thought I post up on here the XP30 issues in case anyone has experience with it and or may run into problems with it. thanks

What I find interesting is you are getting Plasma? errors as in coming from the machine. I really cant see that being back three related.

The reverse letters I think maybe be covered in another thread where you may need to move two wires for each axis on the control board. @langmuir-daniel would be better to answer that and lead you through question one for that matter.

Good Luck and Best Wishes getting it Sorted


Does your machine jog normally? When you press the up arrow key, does the gantry move away from the cable support tube? When you press the right arrow key, does the torch carriage move closer to the unsupported end of the gantry tube?

As for the torch not firing, that could be a number of things. The CrossFire electronics has a simple mechanical relay that completes the same circuit that the trigger otherwise would. I would bet that if you probed trigger wires during the misfire, you would see that the relay is firing normally. I would be extremely surprised if the Hypertherm could tell whether the trigger was pulled or whether the relay was completing the circuit. Something else is causing the issue. I would start with looking at your air supply, consumables, etc.

I personally own a hypertherm Powermax 1000, whenever the pilot arc fails to light, its always as a result of the electrode needing replaced.

I may have them backwards. I always thought the Y axis moved the Torch on the gantry tube. and as you can see in my file here, that’s how I had it set up. When I cut this, it did cut vertically like you are seeing in Fusion. I don’t know if this face side down or not. I def notice if it cut face side down when I’m cutting out fonts. My guess is all my stuff was cutting face side down (meaning dross on the face not backside of material). I’ll switch them around.

As soon as I unplugged the Torch wire the xp30 was then reset and had no error lights. I think what it is, is just a safety feature so you can’t turn the machine on with the trigger held in. Made sense to me bc the controller must have been telling the torch to fire. Maybe I didn’t turn off torch in Mach, but I reset the xp30 like 5 times and it wouldn’t stop giving me errors until I unplugged it from the CNC. Once it was reset I ran program, it cut a little bit and stopped firing. If I recall I it won’t even trigger air or spark, so its not just a lack of spark, but I will confirm that. The program keeps running also but without spark. Would this rule out a CNC controller issue?

Consumables look fine, I originally changed just the tip not the electrode. I know its best to change both. They looked fine to me as they cut a couple things out that was it, no damage I could see. But I did put a new electrode and tip and will try them. Yes I’m using the proper fine tip consumables that hypertherm recommends. One other little note that I think started all of this was, when it first stopped I noticed the tip touching the metal. I normally do a full dry run before I cut, but I just didn’t want to wait for it to run again. So that was my fault. Maybe it did ruin the consumables I dunno but they don’t look ruined. What I don’t get is, I ran a new program the next day, it cut the first shape out flawless and then stopped firing. So if the consumables were bad, why would it cut whole shape perfectly.

Machine jogs and run programs fine without torch on.
I will be adding desiccant soon and oil vapor filters. right now I’m just running a water trap which is temp but perhaps causing issues.
I will try and document more accurate things tonight.
I have a .5 piece delay on the 1/8 material.

Thank again, the forums are great for this stuff. I’m normally on hotrod forums helping others so I know how important they are.

Ok, some resolutions. But had some problems with stopping the torch with the laptop so I had to shut the plasma off. But not all the time. Now when you do that with the Hypertherm this is what happened to me on my initial problem. You go to turn it back on and Mach is telling the plasma to fire but the plasma as a safety won’t let it. So you get a couple blinking lights on the plasma. So… just unplug the plasma from the CNC controller, reset the plasma and make sure torch is off in Mach. Thats only if you have to shut the plasma down physically.

So I put new consumables in, test cut some stuff by hand to rule that out. Worked fine. Set up it up on the CNC and ran some cuts. Everything seemed to run well today. Changed my X and Y axis and I will be honest I am not use to it. i don’t like where my laptop is positioned with the machine so left and right arrows run the X and up and down run the Y. Its like reverse from where I am facing. Wonder if you can change that in mach on what moves the axis? I can’t move the laptop bc the cords are too short. I also put a foam pad under the laptop and moved the plasma farther away from it to rule out some possible interference.

I cut 1/4 at 40 imp piece delay at .8 or 1 I think. I had to slow it down to about %75 in Mach with the Hpertherm XP30.

also cut this sign out of my friend, its about 1/8 I think I ran this at 80imp and pierce at .5 It was going so smooth until the end, had a tip up and it moved the sign or torch. Went back to recut and it was off, so I tried stopping the program and it wouldn’t shut the torch off.

So all in all I’m just having random times when I go to stop a program sometimes the torch will keep running.
But cuts are pretty good I think.

1 Like