Strange issue with Arc (Solved)

I just assembled my crossfire, no THC. Im using a Razorweld 45 with the machine torch. Im having a strange issue where the torch will spark once when trying to pierce and then no arc while its supposed to be cutting. It doesnt pierce even with a 1 second pierce delay. I have checked continuity on the torch on/off port on the electronics enclosure on the table, and I checked the toch on/off cable and it has continuity as well, so I dont think its the relay. I have my torch set at roughly .030" off the material, ground clamp is on clean steel on the workpiece. My compressor is set at 100 PSI and I have my razorweld set around 75 psi, Im getting plenty of air. Im thinking maybe its an issue with the Razorweld but Im open to any and all suggestions.

1 Like

Welcome to the forums.

I would check how your consumable pack is put together again.

Maybe try backing off the retaining ring that holds the consumable slightly just to see if maybe there’s a slight clearance issue.

Maybe try a different set of consumables.


Thank you! I will get that a try

1 Like

I took the torch apart and put it back together, I tried some extra consumables as well and its still doing the same thing. I loosened the torch holder but still nothing changed.

1 Like

@mechanic416 what do you figure on this one?

1 Like

I just figured it out, I ended up taking the plasma cutter apart and checking the continuity on the torch wiring inside the case and everything looked good there. And then I got to thinking about an old super cheap 110v cutter I had a couple years ago and how it would do something similar mid cutting. I ended up checking my 220v outlet in my shop and found one of the hot leads wasnt giving any power. I rewired the outlet and now everything is working! Thank you for help!


That’s great to you got it figured out. And thank you for the update it’ll help someone else in the future when they stumble upon this post.

1 Like