Stepper stops randomly, seems to be an electronics issue

i’ve read several post on steppers that stop and most seem to be a mechanical issue. my issue appears to be an electrical/electronics issue. this is a new install and when i ran the break-in program the y axis would stall and the stepper would make a strange noise like there was a jam or binding. after checking everything mechanical i swapped the x and y axis at the controller and the problem moved to the x axis. so i’m assuming that it is electronics related and something is wrong with the y axis output.

anyone else had this problem? any input?

problem solved…i contacted support and they sent me a new y step drive and harness, i installed today and everything works perfectly now.

BIG thank you to the great langmuir support, they responded within and day and had parts shipped the next day.

2 Likes

Good to hear, thanks for the update.

WOW…surprised to hear this, I inquired Langmuir about a year ago about this same exact issue. they claimed they would send out new stepper motors for me then never did… ive been dealing with this issue for that long because of their garbage customer support! ive inquired them once again because now my steppers refuse to work at all. lets see if they can make good on this because I’m losing my mind over this now!

Looked up the original support ticket from November 2018 and our tech rep sent an email to you with a list of things to check that we never got a response to. I saw that you sent an email this morning to support and I can guarantee that our team will address your issues.

2 Likes

you did get a response. either way. the problem resolved itself somehow. however I will say you guys respond promptly, so ill give you that! hopefully it doesn’t occur again

1 Like