Stepper motor fail? Or controller fail?

Last night both of the stepper motors started behaving oddly. When I jogged in +x direction, it went in the -x direction. After testing it a few times, it worked fine again, then did it again. Also seems to sound like it is loaded when it reverses direction. It has done the same on the y axis, but not as frequently (hint of controller issue?). Power cycled both the computer and the control box, to no avail. Does anyone have some insight as to where to look first?

Check the stepper motor connections at the control box. This happens when the connector is not fully seated and sometimes causes burnt pins on the connector.


sounds like a case of the screws being too tight in the port so it backs out the connector causing it no to have full contact.

unscrew the connectors and remove them from the ports on the control box. Then push them back in until they seat fully but DO NOT screw then back in. If the problem goes away then you need to shave down the ends of the screws a little bit.

1 Like

how clean is everything?

I removed the x & y connectors, blew them off(both sides), and cleaned up the rails. It worked. Thanks.


I clean my table every month and this month I actually took my metal finisher and dressed the rails…cleaned them up nice…

I also lube bearings and drive shafts with sewing machine oil after cleaning them…


Like @toolboy, I too clean up occasionally. You know, dropped ketchup, french fries, spilled beer, that sort of thing. Don’t want things getting too messy…

I’ll add, good on @ds690 for picking up on the connector problem.

1 Like

I do the same but use a fine scotch bright pad when needed. After finishing using for the day I wipe down with a WD40 soaked rag. Then wipe off before using again. Keeps the water stains from building up on the rails as quick. If it’s going to be an extended time without use I throw a piece of outside sunbrella material over it.