Solved: Gantry not in SYNC with DRO (CrossFire Gen1)

Just finished setting up the machine and ran the break in program on Mach3 and everything went well. But then I downloaded Mach4 and tried to run the machine but it didn’t work. So I started Mach3 up again but my gantry moves very slow and when I move the X axis an actual 10 inches, the DRO says 66 inches. When I try and run the break in program the machine collides at the other end of the table. I tried loading Mach3 on two other computers and I’m getting the same error. Any ideas how to fix this?

Hey there!

Did you see my most recent email about the Mach3 Windows 10 patch? I attached the patch to that email, but you can also download the patch at the very bottom of our website’s Downloads page:

To confirm that Mach3 is installed and configured correctly, would you be able to provide screenshots of the following:

  • Mach3 opened on your computer with the ‘Profile’ dialog box visible
  • the location of the CrossFire Mach3 profile (CrossFire-v1.1.xml)
  • the location of the CrossFire Mach3 motion controller plugin (Mach3-CrossFire-MotionControl-v1.dll)
1 Like

Thank you for providing screenshots, I can see the problem.

The image attached below is your screenshot of Mach3 opened on your computer. The Profile dialog box is circled in red, near the bottom-right corner of the Mach3 screen.

The Profile dialog box should say CrossFire-v1.1, it should not say Plasma.

When you launch Mach3, does a pop-up window appear with a list of different profile options to choose from?

1 Like

OK, I figured it out. When I download Mach3 it loads 4 icons on the desk top Mach3Loader, Mach3Turn, Mach3Mill, Mach3Plasma. I assumed I should open the icon that says Plasma since that’s the equipment I want Mach3 to control. So, that’s wrong. You have to open the icon that says Mach3Loader, then you get the choice to choose the CrossFire-v1.1 I didn’t see a note anywhere that explains this. Anyway got it going again.

1 Like