Sheet cam update

updated sheet cam now im getting a error message. Piece Height

An unexpected error occured.
pierce height must below rapid safety clearance
thos error occur on line 1230 in file …

been using this for about 2 years i just updated to the most recent update

I dont use sheet cam, but did you look and see what your rapid safety clearance is set at? Sounds like its to low

1 Like

Under the “options” menu, look at “job options” and see what the rapid clearance value is. Make sure it is set to a value higher than your pierce height.


is there a preset value needed? never actually set any of these before

so now i got that rapid clearance value fix i think and pierce height im getting a message on fire control .
error @ line 39 ( cut height )
Feed Rate has not yet been set or undefinded

i have it set to 50 on the feed ugh any way i can go back to the old version ??

Just guessing, because I haven’t seen this error, but the feed rate for the pierce height line should be the “plunge rate” in your tool settings.

Perhaps some of these values got erased in the update. If you have a “job file”(not a cut file) saved from the old version, open it with the new version and all of your old settings will be there. Just save the toolset from the old job file, before closing the program.

1 Like

i adjusted my plunge rate and was able to get file over to fire control usingold tool and program loaded now i go to cut part but i get an alarm code stating IHS failed the torch is not in the initial state before starting the ihs cycle but i dont have IHS.

also i have program error code -
g code locked out during alarm or jog state. any idea ??? i dont have z axis jus x and y

1 Like

If you don’t have IHS, your pierce and cut heights need to be set at zero in Sheetcam. Otherwise, the post processor adds the IHS commands to probe the torch down to the material and set the Z zero.

With those commands in the code, Firecontrol expects the IHS circuit to be closed. Without a powered Z axis, that circuit is always open.

1 Like

I’m getting the same error when attempting to load a .tap file; even those that had previously worked. the code references the last line of the code. I’ve played around with deleting the last m5 or m30.

Post the .tap file, so we can see what the problem is.

He can’t, newbie.

@sowallis the key thing is to copy the first 20-30 lines and the last 10 lines from your .TAP file into a post so we can check it out.

Welcome to the forum.

I’ve run into issues with FireControl rejecting G-code with an error at the last line. Typically, there is a “(PSxxx)” statement referring to the program speed. (I.E. - at 32 ipm it would list (PS32) ) Occasionally, I’ll get an invalid PS entry there. (Haven’t nailed down why as of yet, but re-processing usually fixes the problem.)