RnR Motion Controller card issue

Looking for suggestions to RnR Motion controller card issue.
After assembly and software installation all was well. Ran the break in program without issue. Shut system down for lunch, returned and fired everything back up and received error in Mach 3. RnR motion card not found and a Windows error USB device not Recognized.
Steps I have done to solve the issue:
Re installed software plugin files, .dll files on pc, also installed on second lap top with same issue. Tried different USB cable, rebooted PC, all the normal things anyone would try. It should be noted my Razorweld cut 45 has not been installed on the machine. I have emailed Langmuir support yesterday and tried several of there suggestions without success. There are no LED lights illuminated on the USB controller card.
Definitely puzzled as the machine and software seem to function just fine, then complete failure after a restart. Any suggestions would be appreciated.

Try a different USB port

Been there done that on two different laptops.

If there are no LED lights illuminating on the USB motion control card when the USB cord is installed, then its a sure sign that it’s malfunctioning. We will get the replacement out to you today.

1 Like

Definitely no LED lights with the usb cable installed. Do you think the system needs to be grounded or a nonconductive material between the control box and the metal frame? I do have other machines in my shop an just wonder if there could be an issue that needs to be addressed to prevent future issues.

You could put a multimeter on the ground pin and the 5-volt pin and see if your getting voltage.

Langmuir is sending me a new controller and I believe that should solve the issue. Just wondering if there is something that caused it or just got a bad card.

1 Like

good luck! We are waiting for our 2nd board …

How long have you been waiting?

First one took just a couple days. Plugged it in and it died within minutes. 2nd one was sent Monday 2 day USPS and haven’t seen it yet. Hopefully tomorrow. Fingers crossed we get back in business.

Actually, waiting for a whole box this time, not just the card.

That does not provide a warm fuzzy feeling! I hope this is not a constant issue to face if they are that sensitive!

Will keep you posted …

FIXED…Langmuir sent a new controller card that i received today. Installed and back up and running.


We are up and going as well … until we ran in to problems with consumables on our plasma cutter. It’s always something sometimes. Replacement box made a world of difference.

1 Like

Georges plasma cutter shop on ebay. I have the Razorweld cut 45, he was great to work with and set me up with what I needed.

I’m all set up & ready to run, but when I push my arrow keys, the motors don’t move? Thaought

I tested the voltage going to this board and I am not reading 5v. So guess I need a new board as well. :frowning:

I tested voltage to the board & no voltage at the ground & 5V pin. I wrote Langmuir asking for another board. No LED light either when the USB plug is plugged in also.

Have you tried a different USB port or different computer?

1 Like